summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-12-14 22:22:43 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-12-14 22:22:43 +0100
commitafb45e0556eee1da8923610b7be9f2fa0985fc0c (patch)
tree3e7a61cd5addb1ab4969b4dc804247200034adaf /sys-libs/glibc
parentsys-libs/glibc: Fix to locale-gen (patchlv) and ebuild for bug 673124 (diff)
downloadgentoo-afb45e0556eee1da8923610b7be9f2fa0985fc0c.tar.gz
gentoo-afb45e0556eee1da8923610b7be9f2fa0985fc0c.tar.bz2
gentoo-afb45e0556eee1da8923610b7be9f2fa0985fc0c.zip
sys-libs/glibc: Rebase patchset, add C.UTF-8, fix bug 673124
Bug: https://bugs.gentoo.org/673124 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/Manifest2
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild4
2 files changed, 3 insertions, 3 deletions
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index 6b62825c1b3d..fb7f9f2c0a25 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -19,4 +19,4 @@ DIST glibc-2.27.tar.xz 15395316 BLAKE2B ea206d304c8c9aa86d69db981a14bea008602cea
DIST glibc-2.28-patches-3.tar.xz 46172 BLAKE2B b2dc4de76ab4b4e31a6a043a133f89ede736cf3f21fb3d3091dabf282b2d70f6d017a4aec37319febb2a43c89176887a0920f2aa174fa98c66ad59cbe19ba493 SHA512 4a40a15f0e8d9ad9d33ea07addc3f07fb952bc9c110549815fb0e78cab818bc64bc8d9150874a80c249bf5765a7a2bb9b6ccfb8bc7b12f30e3807e528506cd71
DIST glibc-2.28-patches-5.tar.xz 76472 BLAKE2B bc3457e606ab7be2eca71c949b70f89d08418e6e2d061491dfcac3b8f962ca142f48bf0f789e025a6280f030d7bf74e3421676b08d97fc571d6e0f4e660d2758 SHA512 1639e435728a9970e4eaa79eb0a00502acecf7060d3bf70ef6bb6256ec20c23b4be6ba500a8ab97547e1af9e3df9228f7b70bb65ea1755b61c7884defa6c3535
DIST glibc-2.28.tar.xz 16484344 BLAKE2B 9aa8cbd5a145c2a6fde3a60b3d0a14b12b46ed79333ad1ca3e73464adcfe700277a17a9e7fd0ca36e355a0c5b0b27decfa091da320ba802741ad75cc955bbcc8 SHA512 521f820953ff07c69ece4c2186f59fc061a7f9747932cd70ef2995c2b2deee76eeb6de700d85071cdca5949179aa8ccee75eda7feca1394121ec7b821ad0a3f3
-DIST glibc-9999-patches-8.tar.xz 14708 BLAKE2B 6c468f11f5b85460219f56ac694e1d3dc3de9a2a23daf7d4f2c715e1b9189bd7a5383093fd8076c2456f9ac0874cb0e2daad8fb360a62038e763a87234f95d95 SHA512 172ab4bc2e716900224b699c9ef89629ffc12756cb72fb7d9628e0ea8fc840cfb2da20ca69fa6c6e1a709f7e2a990bb0f85c32b6ace6fd2d57e2242471900e30
+DIST glibc-9999-patches-9.tar.xz 17384 BLAKE2B d5ddf078a4a9e05a727ba709efdfdb5891e72d19c1a61b11bbde6a555ac38ccc4a1694d46228bbc56ff796e4e16326fb17613d73ccee8b2e6ed51a5bb371a241 SHA512 934bcb0130bd9f3a313b7107528598fb0aac27d719aded265ba111d01eac57e0235e15a4a2d2c7e0376e9d18c803c4b57f9446da4ed3e2b2a62a1587b50dcdbc
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 61685dd31e10..c7e85a20715f 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -28,7 +28,7 @@ RELEASE_VER=${PV}
GCC_BOOTSTRAP_VER=20180511
# Gentoo patchset
-PATCH_VER=8
+PATCH_VER=9
SRC_URI+=" https://dev.gentoo.org/~dilfridge/distfiles/${P}-patches-${PATCH_VER}.tar.xz"
SRC_URI+=" multilib? ( https://dev.gentoo.org/~dilfridge/distfiles/gcc-multilib-bootstrap-${GCC_BOOTSTRAP_VER}.tar.xz )"
@@ -1115,7 +1115,7 @@ run_locale_gen() {
# if the host locales.gen contains no entries, we'll install everything
local root="$1"
local locale_list="${root}/etc/locale.gen"
- if [[ -z $(locale-gen --list --config "${locale_list}") ]] ; then
+ if [[ $(locale-gen --list --config "${locale_list}") == "C.UTF-8" ]] ; then
ewarn "Generating all locales; edit /etc/locale.gen to save time/space"
locale_list="${root}/usr/share/i18n/SUPPORTED"
fi