summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatija Skala <mskala@gmx.com>2018-07-06 19:43:28 +0200
committerSergei Trofimovich <slyfox@gentoo.org>2018-07-07 19:19:59 +0100
commite7d904a382110a59941aab8ca905616276df7ace (patch)
tree93b6d06b6bc3e416e922ac7faa20bf3cdc8abad7 /sys-libs/glibc
parentdev-ruby: cleanup of ruby-gnome 3.0.8 packages (diff)
downloadgentoo-e7d904a382110a59941aab8ca905616276df7ace.tar.gz
gentoo-e7d904a382110a59941aab8ca905616276df7ace.tar.bz2
gentoo-e7d904a382110a59941aab8ca905616276df7ace.zip
sys-libs/glibc: don't check for linux version on non-linux systems
Closes: https://github.com/gentoo/gentoo/pull/9069
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild40
1 files changed, 21 insertions, 19 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 8fe8178fbb4c..a0c2c4f3d45e 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -684,12 +684,6 @@ sanity_prechecks() {
# When we actually have to compile something...
if ! just_headers ; then
- local run_kv build_kv want_kv
-
- run_kv=$(g_get_running_KV)
- build_kv=$(g_int_to_KV $(get_kheader_version))
- want_kv=${MIN_KERN_VER}
-
ebegin "Checking gcc for __thread support"
if ! eend $(want__thread ; echo $?) ; then
echo
@@ -698,21 +692,29 @@ sanity_prechecks() {
die "No __thread support in gcc!"
fi
- if ! is_crosscompile && ! tc-is-cross-compiler ; then
- # Building fails on an non-supporting kernel
- ebegin "Checking running kernel version (${run_kv} >= ${want_kv})"
- if ! eend_KV ${run_kv} ${want_kv} ; then
- echo
- eerror "You need a kernel of at least ${want_kv}!"
- die "Kernel version too low!"
+ if [[ ${CTARGET} == *-linux* ]] ; then
+ local run_kv build_kv want_kv
+
+ run_kv=$(g_get_running_KV)
+ build_kv=$(g_int_to_KV $(get_kheader_version))
+ want_kv=${MIN_KERN_VER}
+
+ if ! is_crosscompile && ! tc-is-cross-compiler ; then
+ # Building fails on an non-supporting kernel
+ ebegin "Checking running kernel version (${run_kv} >= ${want_kv})"
+ if ! eend_KV ${run_kv} ${want_kv} ; then
+ echo
+ eerror "You need a kernel of at least ${want_kv}!"
+ die "Kernel version too low!"
+ fi
fi
- fi
- ebegin "Checking linux-headers version (${build_kv} >= ${want_kv})"
- if ! eend_KV ${build_kv} ${want_kv} ; then
- echo
- eerror "You need linux-headers of at least ${want_kv}!"
- die "linux-headers version too low!"
+ ebegin "Checking linux-headers version (${build_kv} >= ${want_kv})"
+ if ! eend_KV ${build_kv} ${want_kv} ; then
+ echo
+ eerror "You need linux-headers of at least ${want_kv}!"
+ die "linux-headers version too low!"
+ fi
fi
fi
}