summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-01 19:02:58 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-01 19:03:26 +0100
commit23664bcb8930681ff69ae13361add9d5eff5437c (patch)
tree5bf2a09cd8da08ab6e5b8c49df7a49e04eb67be6 /sys-libs/kpmcore
parentapp-emulation/qemu: backport bios link no-pie fix on binutils-2.36 (diff)
downloadgentoo-23664bcb8930681ff69ae13361add9d5eff5437c.tar.gz
gentoo-23664bcb8930681ff69ae13361add9d5eff5437c.tar.bz2
gentoo-23664bcb8930681ff69ae13361add9d5eff5437c.zip
sys-libs/kpmcore: Fix build with KF 5.77.0
Reported-by: Anton <anton@picapica.im> Thanks-to: Andrius Štikonas <andrius@stikonas.eu> Closes: https://bugs.gentoo.org/768249 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-libs/kpmcore')
-rw-r--r--sys-libs/kpmcore/files/kpmcore-4.2.0-kf-5.77.patch50
-rw-r--r--sys-libs/kpmcore/kpmcore-4.2.0.ebuild8
2 files changed, 55 insertions, 3 deletions
diff --git a/sys-libs/kpmcore/files/kpmcore-4.2.0-kf-5.77.patch b/sys-libs/kpmcore/files/kpmcore-4.2.0-kf-5.77.patch
new file mode 100644
index 000000000000..f45ad5a682ba
--- /dev/null
+++ b/sys-libs/kpmcore/files/kpmcore-4.2.0-kf-5.77.patch
@@ -0,0 +1,50 @@
+From 07e5a3ac2858e6d38cc698e0f740e7a693e9f302 Mon Sep 17 00:00:00 2001
+From: "Friedrich W. H. Kossebau" <kossebau@kde.org>
+Date: Mon, 16 Nov 2020 17:14:52 +0100
+Subject: [PATCH] Make plugins compatible to latest KPluginFactory code
+
+That one uses std::is_constructible<impl, QObject *, const QVariantList &>
+which will fail for our current plugin constructors due to being private
+and with only friend class KPluginFactory.
+---
+ src/plugins/dummy/dummybackend.h | 4 +---
+ src/plugins/sfdisk/sfdiskbackend.h | 4 +---
+ 2 files changed, 2 insertions(+), 6 deletions(-)
+
+diff --git a/src/plugins/dummy/dummybackend.h b/src/plugins/dummy/dummybackend.h
+index 815b020..8d67158 100644
+--- a/src/plugins/dummy/dummybackend.h
++++ b/src/plugins/dummy/dummybackend.h
+@@ -24,11 +24,9 @@ class QString;
+ */
+ class DummyBackend : public CoreBackend
+ {
+- friend class KPluginFactory;
+-
+ Q_DISABLE_COPY(DummyBackend)
+
+-private:
++public:
+ DummyBackend(QObject* parent, const QList<QVariant>& args);
+
+ public:
+diff --git a/src/plugins/sfdisk/sfdiskbackend.h b/src/plugins/sfdisk/sfdiskbackend.h
+index e709f61..0571add 100644
+--- a/src/plugins/sfdisk/sfdiskbackend.h
++++ b/src/plugins/sfdisk/sfdiskbackend.h
+@@ -27,11 +27,9 @@ class QString;
+ */
+ class SfdiskBackend : public CoreBackend
+ {
+- friend class KPluginFactory;
+-
+ Q_DISABLE_COPY(SfdiskBackend)
+
+-private:
++public:
+ SfdiskBackend(QObject* parent, const QList<QVariant>& args);
+
+ public:
+--
+GitLab
+
diff --git a/sys-libs/kpmcore/kpmcore-4.2.0.ebuild b/sys-libs/kpmcore/kpmcore-4.2.0.ebuild
index 2103dab3c119..6530cb3632d6 100644
--- a/sys-libs/kpmcore/kpmcore-4.2.0.ebuild
+++ b/sys-libs/kpmcore/kpmcore-4.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,6 +20,9 @@ LICENSE="GPL-3"
SLOT="5/10"
IUSE=""
+# bug 689468, tests need polkit etc.
+RESTRICT+=" test"
+
BDEPEND="
>=kde-frameworks/kauth-${KFMIN}:5
virtual/pkgconfig
@@ -36,5 +39,4 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-# bug 689468, tests need polkit etc.
-RESTRICT+=" test"
+PATCHES=( "${FILESDIR}/${P}-kf-5.77.patch" ) # bug 768249