summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-11-28 00:07:20 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-11-28 00:07:42 +0100
commitb79aa3db1cca97db331e6e058a1c751591f29759 (patch)
tree73dfe3cca7f2b309e815392a6ddc4bb776138ad6 /sys-libs/libaal/libaal-1.0.7-r1.ebuild
parentsys-fs/reiser4progs: Bump to v1.2.0 (diff)
downloadgentoo-b79aa3db1cca97db331e6e058a1c751591f29759.tar.gz
gentoo-b79aa3db1cca97db331e6e058a1c751591f29759.tar.bz2
gentoo-b79aa3db1cca97db331e6e058a1c751591f29759.zip
sys-libs/libaal: Fix build against glibc-2.6
Closes: https://bugs.gentoo.org/637610 Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'sys-libs/libaal/libaal-1.0.7-r1.ebuild')
-rw-r--r--sys-libs/libaal/libaal-1.0.7-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-libs/libaal/libaal-1.0.7-r1.ebuild b/sys-libs/libaal/libaal-1.0.7-r1.ebuild
new file mode 100644
index 000000000000..bd15352a4c18
--- /dev/null
+++ b/sys-libs/libaal/libaal-1.0.7-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="library required by reiser4progs"
+HOMEPAGE="https://sourceforge.net/projects/reiser4/"
+SRC_URI="mirror://sourceforge/reiser4/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/7"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 -sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="virtual/os-headers"
+
+src_prepare() {
+ default
+
+ # remove stupid CFLAG hardcodes
+ sed -i \
+ -e "/GENERIC_CFLAGS/s:-O3::" \
+ -e "/^CFLAGS=/s:\"\":\"${CFLAGS}\":" \
+ configure || die
+ printf '#!/bin/sh\n:\n' > run-ldconfig || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-libminimal
+ --enable-memory-manager
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ gen_usr_ldscript -a aal{,-minimal}
+}