summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-20 08:31:04 +0000
committerSam James <sam@gentoo.org>2021-11-20 08:31:04 +0000
commitc344ef7f386fc3c3090eb1bc36ec713b80f17ff0 (patch)
tree05fc0ea98fa8dd2b3b44a6c332ec9e215ea5a2e3 /sys-libs/libcap
parentsys-libs/libcap: backport alignment fixes (diff)
downloadgentoo-c344ef7f386fc3c3090eb1bc36ec713b80f17ff0.tar.gz
gentoo-c344ef7f386fc3c3090eb1bc36ec713b80f17ff0.tar.bz2
gentoo-c344ef7f386fc3c3090eb1bc36ec713b80f17ff0.zip
sys-libs/libcap: cleanup patches
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/libcap')
-rw-r--r--sys-libs/libcap/files/libcap-2.25-ignore-RAISE_SETFCAP-install-failures.patch9
-rw-r--r--sys-libs/libcap/files/libcap-2.38-no_perl.patch9
-rw-r--r--sys-libs/libcap/files/libcap-2.48-build-system-fixes.patch24
3 files changed, 0 insertions, 42 deletions
diff --git a/sys-libs/libcap/files/libcap-2.25-ignore-RAISE_SETFCAP-install-failures.patch b/sys-libs/libcap/files/libcap-2.25-ignore-RAISE_SETFCAP-install-failures.patch
index 0f737361a4d1..e5455cd1ebb6 100644
--- a/sys-libs/libcap/files/libcap-2.25-ignore-RAISE_SETFCAP-install-failures.patch
+++ b/sys-libs/libcap/files/libcap-2.25-ignore-RAISE_SETFCAP-install-failures.patch
@@ -11,12 +11,6 @@ Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Forward ported from libcap-2.20 to libcap-2.25
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
----
- progs/Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/progs/Makefile b/progs/Makefile
-index c094a24..4a6db38 100644
--- a/progs/Makefile
+++ b/progs/Makefile
@@ -27,7 +27,7 @@ install: all
@@ -28,6 +22,3 @@ index c094a24..4a6db38 100644
endif
clean:
---
-2.7.1
-
diff --git a/sys-libs/libcap/files/libcap-2.38-no_perl.patch b/sys-libs/libcap/files/libcap-2.38-no_perl.patch
index f3e0c468c869..9104484d5770 100644
--- a/sys-libs/libcap/files/libcap-2.38-no_perl.patch
+++ b/sys-libs/libcap/files/libcap-2.38-no_perl.patch
@@ -14,12 +14,6 @@ Forward ported from libcap-2.26 to libcap-2.28
Forward ported from libcap-2.28 to libcap-2.38
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
----
- libcap/Makefile | 26 +++++++++++++++++++-------
- 1 file changed, 19 insertions(+), 7 deletions(-)
-
-diff --git a/libcap/Makefile b/libcap/Makefile
-index 3d6463d..df2526c 100644
--- a/libcap/Makefile
+++ b/libcap/Makefile
@@ -22,6 +22,8 @@ MAJLIBNAME=$(LIBNAME).$(VERSION)
@@ -66,6 +60,3 @@ index 3d6463d..df2526c 100644
$(STACAPLIBNAME): $(CAPOBJS)
$(AR) rcs $@ $^
---
-2.27.0
-
diff --git a/sys-libs/libcap/files/libcap-2.48-build-system-fixes.patch b/sys-libs/libcap/files/libcap-2.48-build-system-fixes.patch
index a672ecedaca6..b3986e19546c 100644
--- a/sys-libs/libcap/files/libcap-2.48-build-system-fixes.patch
+++ b/sys-libs/libcap/files/libcap-2.48-build-system-fixes.patch
@@ -27,17 +27,6 @@ Forward ported from libcap-2.44 to libcap-2.45
Forward ported from libcap-2.45 to libcap-2.48
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
----
- Make.Rules | 10 ++++++----
- Makefile | 1 -
- libcap/Makefile | 7 ++++---
- pam_cap/Makefile | 8 +++++---
- progs/Makefile | 2 +-
- tests/Makefile | 6 ++++--
- 6 files changed, 20 insertions(+), 14 deletions(-)
-
-diff --git a/Make.Rules b/Make.Rules
-index ded9014..07b716f 100644
--- a/Make.Rules
+++ b/Make.Rules
@@ -52,7 +52,6 @@ GOMAJOR=0
@@ -73,8 +62,6 @@ index ded9014..07b716f 100644
INDENT := $(shell if [ -n "$$(which indent 2>/dev/null)" ]; then echo "| indent -kr" ; fi)
# SHARED tracks whether or not the SHARED libraries (libcap.so,
-diff --git a/Makefile b/Makefile
-index 7150b9b..9dff1e9 100644
--- a/Makefile
+++ b/Makefile
@@ -17,7 +17,6 @@ ifeq ($(GOLANG),yes)
@@ -85,8 +72,6 @@ index 7150b9b..9dff1e9 100644
$(MAKE) -C progs $@
$(MAKE) -C doc $@
$(MAKE) -C kdebug $@
-diff --git a/libcap/Makefile b/libcap/Makefile
-index 9563d88..4b42f01 100644
--- a/libcap/Makefile
+++ b/libcap/Makefile
@@ -25,6 +25,7 @@ MINCAPLIBNAME=$(MAJCAPLIBNAME).$(MINOR)
@@ -119,8 +104,6 @@ index 9563d88..4b42f01 100644
cap_test: cap_test.c libcap.h
$(CC) $(CFLAGS) $(IPATH) $< -o $@
-diff --git a/pam_cap/Makefile b/pam_cap/Makefile
-index 56604fd..2da4674 100644
--- a/pam_cap/Makefile
+++ b/pam_cap/Makefile
@@ -3,6 +3,8 @@
@@ -152,8 +135,6 @@ index 56604fd..2da4674 100644
test: pam_cap.so
make testlink
-diff --git a/progs/Makefile b/progs/Makefile
-index 1d7fc7a..64dbe86 100644
--- a/progs/Makefile
+++ b/progs/Makefile
@@ -28,7 +28,7 @@ $(BUILD): %: %.o $(DEPS)
@@ -165,8 +146,6 @@ index 1d7fc7a..64dbe86 100644
install: all
mkdir -p -m 0755 $(FAKEROOT)$(SBINDIR)
-diff --git a/tests/Makefile b/tests/Makefile
-index 1e7039d..5874624 100644
--- a/tests/Makefile
+++ b/tests/Makefile
@@ -13,6 +13,8 @@ ifeq ($(PTHREADS),yes)
@@ -194,6 +173,3 @@ index 1e7039d..5874624 100644
# privileged
run_libcap_launch_test: libcap_launch_test noop ../progs/tcapsh-static
---
-2.30.0
-