summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2016-04-26 08:39:59 -0500
committerDoug Goldstein <cardoe@gentoo.org>2016-04-26 08:39:59 -0500
commitc6a8a1f867f3062da4deb35d09642ec07032ddd8 (patch)
tree6ff18482d65fff346d56f3b8573ceb11316c24da /sys-libs/libseccomp/libseccomp-2.3.1.ebuild
parentdev-python/dulwich: remove old (diff)
downloadgentoo-c6a8a1f867f3062da4deb35d09642ec07032ddd8.tar.gz
gentoo-c6a8a1f867f3062da4deb35d09642ec07032ddd8.tar.bz2
gentoo-c6a8a1f867f3062da4deb35d09642ec07032ddd8.zip
sys-libs/libseccomp: version bump
Package-Manager: portage-2.2.26 Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
Diffstat (limited to 'sys-libs/libseccomp/libseccomp-2.3.1.ebuild')
-rw-r--r--sys-libs/libseccomp/libseccomp-2.3.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-libs/libseccomp/libseccomp-2.3.1.ebuild b/sys-libs/libseccomp/libseccomp-2.3.1.ebuild
new file mode 100644
index 000000000000..ad6a115e0fe8
--- /dev/null
+++ b/sys-libs/libseccomp/libseccomp-2.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: Add python support.
+
+EAPI="5"
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="high level interface to Linux seccomp filter"
+HOMEPAGE="https://github.com/seccomp/libseccomp"
+SRC_URI="https://github.com/seccomp/libseccomp/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~s390 ~x86"
+IUSE="static-libs"
+
+# We need newer kernel headers; we don't keep strict control of the exact
+# version here, just be safe and pull in the latest stable ones. #551248
+DEPEND=">=sys-kernel/linux-headers-4.3"
+
+src_prepare() {
+ sed -i \
+ -e '/_LDFLAGS/s:-static::' \
+ tools/Makefile.in || die
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable static-libs static) \
+ --disable-python
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name libseccomp.la -delete
+ einstalldocs
+}