summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-09-03 21:54:40 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-09-03 22:00:09 +0200
commit0f050813172ebe21703e826e870352fe97d0b8af (patch)
treedf7907601370eb34b538d7fc8a840e61a2a42b35 /sys-libs/libseccomp/libseccomp-2.4.4.ebuild
parentdev-python/django: Remove old (diff)
downloadgentoo-0f050813172ebe21703e826e870352fe97d0b8af.tar.gz
gentoo-0f050813172ebe21703e826e870352fe97d0b8af.tar.bz2
gentoo-0f050813172ebe21703e826e870352fe97d0b8af.zip
sys-libs/libseccomp: Bump to version 2.4.4
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/libseccomp/libseccomp-2.4.4.ebuild')
-rw-r--r--sys-libs/libseccomp/libseccomp-2.4.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-libs/libseccomp/libseccomp-2.4.4.ebuild b/sys-libs/libseccomp/libseccomp-2.4.4.ebuild
new file mode 100644
index 000000000000..5224cb3571a8
--- /dev/null
+++ b/sys-libs/libseccomp/libseccomp-2.4.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: Add python support.
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="high level interface to Linux seccomp filter"
+HOMEPAGE="https://github.com/seccomp/libseccomp"
+SRC_URI="https://github.com/seccomp/libseccomp/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+# We need newer kernel headers; we don't keep strict control of the exact
+# version here, just be safe and pull in the latest stable ones. #551248
+DEPEND=">=sys-kernel/linux-headers-4.3"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/_LDFLAGS/s:-static::' \
+ tools/Makefile.in || die
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ --disable-python
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name "${PN}.la" -delete || die
+ einstalldocs
+}