summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-07-21 10:25:10 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-07-21 10:32:22 +0200
commitbdd9d770642b91e59b71b6e018db6888a0beba84 (patch)
treead0f0defc7a291611dc09b36e132d0fa725f90b1 /sys-libs/libseccomp
parentsys-libs/libseccomp: New live ebuild (diff)
downloadgentoo-bdd9d770642b91e59b71b6e018db6888a0beba84.tar.gz
gentoo-bdd9d770642b91e59b71b6e018db6888a0beba84.tar.bz2
gentoo-bdd9d770642b91e59b71b6e018db6888a0beba84.zip
sys-libs/libseccomp: Minor improvements for the live ebuild
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/libseccomp')
-rw-r--r--sys-libs/libseccomp/libseccomp-9999.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/sys-libs/libseccomp/libseccomp-9999.ebuild b/sys-libs/libseccomp/libseccomp-9999.ebuild
index 5604393c136c..a70a1f90aa97 100644
--- a/sys-libs/libseccomp/libseccomp-9999.ebuild
+++ b/sys-libs/libseccomp/libseccomp-9999.ebuild
@@ -3,15 +3,6 @@
EAPI=7
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/seccomp/libseccomp.git"
- PRERELEASE="2.5.0"
- inherit autotools git-r3
-else
- SRC_URI="https://github.com/seccomp/libseccomp/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="-* ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux"
-fi
-
PYTHON_COMPAT=( python3_{6..9} )
DISTUTILS_OPTIONAL=1
@@ -20,6 +11,15 @@ inherit distutils-r1 multilib-minimal
DESCRIPTION="high level interface to Linux seccomp filter"
HOMEPAGE="https://github.com/seccomp/libseccomp"
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/seccomp/libseccomp.git"
+ PRERELEASE="2.6.0"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/seccomp/libseccomp/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="-* ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux"
+fi
+
LICENSE="LGPL-2.1"
SLOT="0"
IUSE="python static-libs"
@@ -55,7 +55,9 @@ multilib_src_compile() {
if multilib_is_native_abi && use python ; then
cd "${S}/src/python" || die
- sed -i -e "s/=.*VERSION_RELEASE.*,/=\"${PRERELEASE}\",/" -e "/extra_objects/s,\.\.,${OLDPWD}/src," setup.py
+ sed -i -e "s/=.*VERSION_RELEASE.*,/=\"${PRERELEASE}\",/" \
+ -e "/extra_objects/s,\.\.,${OLDPWD}/src," \
+ setup.py || die
local -x CPPFLAGS="-I${OLDPWD}/include -I../../include"
distutils-r1_src_compile
fi