summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-24 19:34:27 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-24 20:07:55 +0100
commit3046049a905658592d44f3284abe66e2f27e4018 (patch)
treeb735a34a0ea59fcbb5683c8829e8cb01cb871ae1 /sys-libs/llvm-libunwind/llvm-libunwind-4.0.0_rc1.ebuild
parentsys-libs/compiler-rt-sanitizers: Switch 4.0.0rc1 to tarballs, add keywords (diff)
downloadgentoo-3046049a905658592d44f3284abe66e2f27e4018.tar.gz
gentoo-3046049a905658592d44f3284abe66e2f27e4018.tar.bz2
gentoo-3046049a905658592d44f3284abe66e2f27e4018.zip
sys-libs/llvm-libunwind: Switch 4.0.0rc1 to tarballs, add keywords
Diffstat (limited to 'sys-libs/llvm-libunwind/llvm-libunwind-4.0.0_rc1.ebuild')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-4.0.0_rc1.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-4.0.0_rc1.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-4.0.0_rc1.ebuild
index f824d98314ef..bdf6b108c4ab 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-4.0.0_rc1.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-4.0.0_rc1.ebuild
@@ -7,25 +7,23 @@ EAPI=6
: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
# (needed due to CMAKE_BUILD_TYPE != Gentoo)
CMAKE_MIN_VERSION=3.7.0-r1
-inherit cmake-multilib git-r3
+inherit cmake-multilib
DESCRIPTION="C++ runtime stack unwinder from LLVM"
HOMEPAGE="https://github.com/llvm-mirror/libunwind"
-SRC_URI=""
-EGIT_REPO_URI="http://llvm.org/git/libunwind.git
- https://github.com/llvm-mirror/libunwind.git"
-EGIT_BRANCH="release_40"
-EGIT_COMMIT="9f88e323c3d0926f52ab3d4a5379eefd92ff28c2"
+SRC_URI="http://www.llvm.org/pre-releases/${PV/_//}/libunwind-${PV/_/}.src.tar.xz"
LICENSE="|| ( UoI-NCSA MIT )"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="debug +static-libs"
RDEPEND="!sys-libs/libunwind"
# LLVM 4 required for llvm-config --cmakedir
DEPEND=">=sys-devel/llvm-4"
+S=${WORKDIR}/libunwind-${PV/_/}.src
+
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo