summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Kuehn <daniel@kuehn.se>2016-07-25 22:56:19 +0200
committerDaniel Kuehn <lejonet@gentoo.org>2016-07-25 23:03:19 +0200
commit0975334b5b21b0afd0e12632f77fcec65392329b (patch)
treed2b4340026cbad444ad633a69391be5d2e511320 /sys-libs/musl-nscd/musl-nscd-9999.ebuild
parentx11-wm/page: version bump. (diff)
downloadgentoo-0975334b5b21b0afd0e12632f77fcec65392329b.tar.gz
gentoo-0975334b5b21b0afd0e12632f77fcec65392329b.tar.bz2
gentoo-0975334b5b21b0afd0e12632f77fcec65392329b.zip
sys-libs/musl-nscd: Added musl-nscd
Added a live ebuild for musl-nscd, a thin Name Service System "wrapper" for musl libc, highly experimental.
Diffstat (limited to 'sys-libs/musl-nscd/musl-nscd-9999.ebuild')
-rw-r--r--sys-libs/musl-nscd/musl-nscd-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-libs/musl-nscd/musl-nscd-9999.ebuild b/sys-libs/musl-nscd/musl-nscd-9999.ebuild
new file mode 100644
index 000000000000..a85cf6301086
--- /dev/null
+++ b/sys-libs/musl-nscd/musl-nscd-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit git-r3 systemd
+
+DESCRIPTION="musl-nscd is an implementation of the NSCD protocol for the musl libc"
+HOMEPAGE="https://github.com/pikhq/musl-nscd"
+EGIT_REPO_URI="https://github.com/pikhq/musl-nscd"
+EGIT_BRANCH=master
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="minimal"
+
+src_install() {
+ if use minimal; then
+ emake DESTDIR="${D}" install-headers
+ else
+ emake DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}"/nscd.initd nscd
+ systemd_dounit "${FILESDIR}"/nscd.service
+ systemd_newtmpfilesd "${FILESDIR}"/nscd.tmpfilesd nscd.conf
+
+ dodoc README
+ fi
+}