summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-04-04 14:30:21 -0400
committerMike Gilbert <floppym@gentoo.org>2021-04-04 14:30:28 -0400
commit5ed2fa287a431d6dc8e346b6f6e9ca2f76892c24 (patch)
tree36ff0e66ce0a0141b603d5f63e8e7aa75f8f09db /sys-libs/ncurses-compat
parentsys-devel/dev86: avoid D in src_compile (diff)
downloadgentoo-5ed2fa287a431d6dc8e346b6f6e9ca2f76892c24.tar.gz
gentoo-5ed2fa287a431d6dc8e346b6f6e9ca2f76892c24.tar.bz2
gentoo-5ed2fa287a431d6dc8e346b6f6e9ca2f76892c24.zip
sys-libs/ncurses-compat: remove ROOT=/ in front of has_version -b
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-libs/ncurses-compat')
-rw-r--r--sys-libs/ncurses-compat/ncurses-compat-6.1_p20190609.ebuild6
-rw-r--r--sys-libs/ncurses-compat/ncurses-compat-6.2.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/sys-libs/ncurses-compat/ncurses-compat-6.1_p20190609.ebuild b/sys-libs/ncurses-compat/ncurses-compat-6.1_p20190609.ebuild
index a111d7887698..cbf320d863af 100644
--- a/sys-libs/ncurses-compat/ncurses-compat-6.1_p20190609.ebuild
+++ b/sys-libs/ncurses-compat/ncurses-compat-6.1_p20190609.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# This version is just for the ABI .5 library
@@ -69,7 +69,7 @@ src_configure() {
# This comes up when cross-compiling, doing multilib builds, upgrading,
# or installing for the first time. Build a local copy of tic whenever
# the host version isn't available. #249363 #557598
- if ! ROOT=/ has_version -b "~sys-libs/${P}:0" ; then
+ if ! has_version -b "~sys-libs/${P}:0" ; then
local lbuildflags="-static"
# some toolchains don't quite support static linking
@@ -181,7 +181,7 @@ do_configure() {
src_compile() {
# See comments in src_configure.
- if ! ROOT=/ has_version -b "~sys-libs/${P}:0" ; then
+ if ! has_version -b "~sys-libs/${P}:0" ; then
BUILD_DIR="${WORKDIR}" \
do_compile cross -C progs tic
fi
diff --git a/sys-libs/ncurses-compat/ncurses-compat-6.2.ebuild b/sys-libs/ncurses-compat/ncurses-compat-6.2.ebuild
index 13a0da5e700c..0484acd9547a 100644
--- a/sys-libs/ncurses-compat/ncurses-compat-6.2.ebuild
+++ b/sys-libs/ncurses-compat/ncurses-compat-6.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# This version is just for the ABI .5 library
@@ -69,7 +69,7 @@ src_configure() {
# This comes up when cross-compiling, doing multilib builds, upgrading,
# or installing for the first time. Build a local copy of tic whenever
# the host version isn't available. #249363 #557598
- if ! ROOT=/ has_version -b "~sys-libs/${P}:0" ; then
+ if ! has_version -b "~sys-libs/${P}:0" ; then
local lbuildflags="-static"
# some toolchains don't quite support static linking
@@ -181,7 +181,7 @@ do_configure() {
src_compile() {
# See comments in src_configure.
- if ! ROOT=/ has_version -b "~sys-libs/${P}:0" ; then
+ if ! has_version -b "~sys-libs/${P}:0" ; then
BUILD_DIR="${WORKDIR}" \
do_compile cross -C progs tic
fi