summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2023-01-20 18:53:01 -0500
committerMike Frysinger <vapier@gentoo.org>2023-01-20 18:53:55 -0500
commitb9f590f6d4b7c2fdba372fc5d2586042c565087d (patch)
tree1bf1b6f6919c1f3df4362f202b80fa8bce897376 /sys-libs/newlib/newlib-9999.ebuild
parentapp-misc/golly: add doc link to metadata.xml (diff)
downloadgentoo-b9f590f6d4b7c2fdba372fc5d2586042c565087d.tar.gz
gentoo-b9f590f6d4b7c2fdba372fc5d2586042c565087d.tar.bz2
gentoo-b9f590f6d4b7c2fdba372fc5d2586042c565087d.zip
sys-libs/newlib: allow parallel install again
The upstream build system has been heavily rewritten and shouldn't have any parallel install bugs in it anymore. If there are any left, they should get fixed, so let's re enable parallel install. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'sys-libs/newlib/newlib-9999.ebuild')
-rw-r--r--sys-libs/newlib/newlib-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-libs/newlib/newlib-9999.ebuild b/sys-libs/newlib/newlib-9999.ebuild
index 83237271fd55..5b16a3bf6787 100644
--- a/sys-libs/newlib/newlib-9999.ebuild
+++ b/sys-libs/newlib/newlib-9999.ebuild
@@ -128,11 +128,11 @@ src_compile() {
src_install() {
cd "${NEWLIBBUILD}" || die
- emake -j1 DESTDIR="${D}" install
+ emake DESTDIR="${D}" install
if use nano ; then
cd "${NEWLIBNANOBUILD}" || die
- emake -j1 DESTDIR="${NEWLIBNANOTMPINSTALL}" install
+ emake DESTDIR="${NEWLIBNANOTMPINSTALL}" install
# Rename nano lib* files to lib*_nano and move to the real ${D}
local nanolibfiles=""
nanolibfiles=$(find "${NEWLIBNANOTMPINSTALL}" -regex ".*/lib\(c\|g\|m\|rdimon\|gloss\)\.a" -print)