summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-06 02:28:55 +0000
committerSam James <sam@gentoo.org>2021-11-06 02:29:48 +0000
commitaeb526aa3b0875745fa0af6c754ded21af68658b (patch)
tree4429a08e69f62b2f045d5b9d0a3ceb5e2b48e340 /sys-libs/pam
parentdev-lang/python: add 3.11.0_alpha2 (diff)
downloadgentoo-aeb526aa3b0875745fa0af6c754ded21af68658b.tar.gz
gentoo-aeb526aa3b0875745fa0af6c754ded21af68658b.tar.bz2
gentoo-aeb526aa3b0875745fa0af6c754ded21af68658b.zip
sys-libs/pam: drop usrscript
This shouldn't be necessary anymore but let's do it in a new revision in ~arch to be safe. See: 2ff9dcc3275e4f37a44eaf707fce9f53c13c2e82 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/pam')
-rw-r--r--sys-libs/pam/pam-1.5.1-r1.ebuild4
-rw-r--r--sys-libs/pam/pam-1.5.1_p20210622-r1.ebuild4
-rw-r--r--sys-libs/pam/pam-1.5.2-r1.ebuild128
-rw-r--r--sys-libs/pam/pam-1.5.2.ebuild4
4 files changed, 137 insertions, 3 deletions
diff --git a/sys-libs/pam/pam-1.5.1-r1.ebuild b/sys-libs/pam/pam-1.5.1-r1.ebuild
index 9d9ffe7141ed..61fbf74ec472 100644
--- a/sys-libs/pam/pam-1.5.1-r1.ebuild
+++ b/sys-libs/pam/pam-1.5.1-r1.ebuild
@@ -9,7 +9,7 @@ MY_P="Linux-${PN^^}-${PV}"
# Can reconsider w/ EAPI 8 and IDEPEND, bug #810979
TMPFILES_OPTIONAL=1
-inherit autotools db-use fcaps toolchain-funcs multilib-minimal
+inherit autotools db-use fcaps toolchain-funcs usr-ldscript multilib-minimal
DESCRIPTION="Linux-PAM (Pluggable Authentication Modules)"
HOMEPAGE="https://github.com/linux-pam/linux-pam"
@@ -92,6 +92,8 @@ multilib_src_compile() {
multilib_src_install() {
emake DESTDIR="${D}" install \
sepermitlockdir="/run/sepermit"
+
+ gen_usr_ldscript -a pam pam_misc pamc
}
multilib_src_install_all() {
diff --git a/sys-libs/pam/pam-1.5.1_p20210622-r1.ebuild b/sys-libs/pam/pam-1.5.1_p20210622-r1.ebuild
index 4c18a7e8cffb..bbc95832d99a 100644
--- a/sys-libs/pam/pam-1.5.1_p20210622-r1.ebuild
+++ b/sys-libs/pam/pam-1.5.1_p20210622-r1.ebuild
@@ -7,7 +7,7 @@ EAPI=7
# Can reconsider w/ EAPI 8 and IDEPEND, bug #810979
TMPFILES_OPTIONAL=1
-inherit autotools db-use fcaps toolchain-funcs multilib-minimal
+inherit autotools db-use fcaps toolchain-funcs usr-ldscript multilib-minimal
GIT_COMMIT="fe1307512fb8892b5ceb3d884c793af8dbd4c16a"
DOC_SNAPSHOT="20210610"
@@ -87,6 +87,8 @@ multilib_src_compile() {
multilib_src_install() {
emake DESTDIR="${D}" install \
sepermitlockdir="/run/sepermit"
+
+ gen_usr_ldscript -a pam pam_misc pamc
}
multilib_src_install_all() {
diff --git a/sys-libs/pam/pam-1.5.2-r1.ebuild b/sys-libs/pam/pam-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..77719a8fded9
--- /dev/null
+++ b/sys-libs/pam/pam-1.5.2-r1.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="Linux-${PN^^}-${PV}"
+
+# Avoid QA warnings
+# Can reconsider w/ EAPI 8 and IDEPEND, bug #810979
+TMPFILES_OPTIONAL=1
+
+inherit autotools db-use fcaps toolchain-funcs multilib-minimal
+
+DESCRIPTION="Linux-PAM (Pluggable Authentication Modules)"
+HOMEPAGE="https://github.com/linux-pam/linux-pam"
+
+SRC_URI="https://github.com/linux-pam/linux-pam/releases/download/v${PV}/${MY_P}.tar.xz
+ https://github.com/linux-pam/linux-pam/releases/download/v${PV}/${MY_P}-docs.tar.xz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="audit berkdb debug nis selinux"
+
+BDEPEND="
+ dev-libs/libxslt
+ sys-devel/flex
+ sys-devel/gettext
+ virtual/pkgconfig
+ virtual/yacc
+"
+
+DEPEND="
+ virtual/libcrypt:=[${MULTILIB_USEDEP}]
+ >=virtual/libintl-0-r1[${MULTILIB_USEDEP}]
+ audit? ( >=sys-process/audit-2.2.2[${MULTILIB_USEDEP}] )
+ berkdb? ( >=sys-libs/db-4.8.30-r1:=[${MULTILIB_USEDEP}] )
+ selinux? ( >=sys-libs/libselinux-2.2.2-r4[${MULTILIB_USEDEP}] )
+ nis? ( net-libs/libnsl:=[${MULTILIB_USEDEP}]
+ >=net-libs/libtirpc-0.2.4-r2:=[${MULTILIB_USEDEP}] )"
+
+RDEPEND="${DEPEND}"
+
+PDEPEND=">=sys-auth/pambase-20200616"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ touch ChangeLog || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # Do not let user's BROWSER setting mess us up. #549684
+ unset BROWSER
+
+ local myconf=(
+ CC_FOR_BUILD="$(tc-getBUILD_CC)"
+ --with-db-uniquename=-$(db_findver sys-libs/db)
+ --with-xml-catalog=/etc/xml/catalog
+ --enable-securedir=/$(get_libdir)/security
+ --includedir=/usr/include/security
+ --libdir=/usr/$(get_libdir)
+ --enable-pie
+ --enable-unix
+ --disable-prelude
+ --disable-doc
+ --disable-regenerate-docu
+ --disable-static
+ --disable-Werror
+ $(use_enable audit)
+ $(use_enable berkdb db)
+ $(use_enable debug)
+ $(use_enable nis)
+ $(use_enable selinux)
+ --enable-isadir='.' #464016
+ )
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ emake sepermitlockdir="/run/sepermit"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install \
+ sepermitlockdir="/run/sepermit"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name '*.la' -delete || die
+
+ # tmpfiles.eclass is impossible to use because
+ # there is the pam -> tmpfiles -> systemd -> pam dependency loop
+
+ dodir /usr/lib/tmpfiles.d
+
+ cat ->> "${D}"/usr/lib/tmpfiles.d/${CATEGORY}-${PN}.conf <<-_EOF_
+ d /run/faillock 0755 root root
+ _EOF_
+ use selinux && cat ->> "${D}"/usr/lib/tmpfiles.d/${CATEGORY}-${PN}-selinux.conf <<-_EOF_
+ d /run/sepermit 0755 root root
+ _EOF_
+
+ local page
+
+ for page in doc/man/*.{3,5,8} modules/*/*.{5,8} ; do
+ doman ${page}
+ done
+}
+
+pkg_postinst() {
+ ewarn "Some software with pre-loaded PAM libraries might experience"
+ ewarn "warnings or failures related to missing symbols and/or versions"
+ ewarn "after any update. While unfortunate this is a limit of the"
+ ewarn "implementation of PAM and the software, and it requires you to"
+ ewarn "restart the software manually after the update."
+ ewarn ""
+ ewarn "You can get a list of such software running a command like"
+ ewarn " lsof / | egrep -i 'del.*libpam\\.so'"
+ ewarn ""
+ ewarn "Alternatively, simply reboot your system."
+
+ # The pam_unix module needs to check the password of the user which requires
+ # read access to /etc/shadow only.
+ fcaps cap_dac_override sbin/unix_chkpwd
+}
diff --git a/sys-libs/pam/pam-1.5.2.ebuild b/sys-libs/pam/pam-1.5.2.ebuild
index 77719a8fded9..12fb3126d89c 100644
--- a/sys-libs/pam/pam-1.5.2.ebuild
+++ b/sys-libs/pam/pam-1.5.2.ebuild
@@ -9,7 +9,7 @@ MY_P="Linux-${PN^^}-${PV}"
# Can reconsider w/ EAPI 8 and IDEPEND, bug #810979
TMPFILES_OPTIONAL=1
-inherit autotools db-use fcaps toolchain-funcs multilib-minimal
+inherit autotools db-use fcaps toolchain-funcs usr-ldscript multilib-minimal
DESCRIPTION="Linux-PAM (Pluggable Authentication Modules)"
HOMEPAGE="https://github.com/linux-pam/linux-pam"
@@ -86,6 +86,8 @@ multilib_src_compile() {
multilib_src_install() {
emake DESTDIR="${D}" install \
sepermitlockdir="/run/sepermit"
+
+ gen_usr_ldscript -a pam pam_misc pamc
}
multilib_src_install_all() {