summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-08-14 21:24:34 -0700
committerMatt Turner <mattst88@gentoo.org>2020-08-15 12:10:44 -0700
commitf703af0874edebde27531376271ebc18c487adcd (patch)
tree62d5b0fcb7e11c5ef1d4ceca5a0d142e08ff85ef /sys-libs/pam_wrapper/pam_wrapper-1.1.3.ebuild
parentdev-db/postgresql: stable 9.6.19 for hppa, bug #737032 (diff)
downloadgentoo-f703af0874edebde27531376271ebc18c487adcd.tar.gz
gentoo-f703af0874edebde27531376271ebc18c487adcd.tar.bz2
gentoo-f703af0874edebde27531376271ebc18c487adcd.zip
sys-libs/pam_wrapper: Add new package
Closes: https://bugs.gentoo.org/730974 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-libs/pam_wrapper/pam_wrapper-1.1.3.ebuild')
-rw-r--r--sys-libs/pam_wrapper/pam_wrapper-1.1.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-libs/pam_wrapper/pam_wrapper-1.1.3.ebuild b/sys-libs/pam_wrapper/pam_wrapper-1.1.3.ebuild
new file mode 100644
index 000000000000..517f2391cbeb
--- /dev/null
+++ b/sys-libs/pam_wrapper/pam_wrapper-1.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+CMAKE_ECLASS=cmake
+inherit cmake-multilib python-single-r1
+
+DESCRIPTION="A tool to test PAM applications and PAM modules"
+HOMEPAGE="https://cwrap.org/pam_wrapper.html"
+SRC_URI="https://www.samba.org/ftp/pub/cwrap/${P}.tar.gz
+ https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ sys-libs/pam:0=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ local libpam="${EPREFIX}"
+ multilib_is_native_abi || libpam+="/usr"
+ libpam+="/$(get_libdir)/libpam.so.0"
+
+ local mycmakeargs=(
+ -DPAM_LIBRARY="${libpam}"
+ -DUNIT_TESTING=$(usex test)
+ -DPYTHON2_LIBRARY="/dev/null" # Disabled
+ -DPYTHON3_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON3_SITELIB="$(python_get_sitedir)"
+ )
+ cmake_src_configure
+}