summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-03-29 07:28:12 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-03-29 07:28:12 -0400
commit1ffea40c4a42bba612604c22f56cafc46f5fb4da (patch)
tree0c59e20744e0432229c62742085b440a86c1cc92 /sys-libs/rpmatch-standalone/rpmatch-standalone-1.0.ebuild
parentsys-devel/llvm: Remove non-arm & non-Darwin keywords from 3.7.1 (diff)
downloadgentoo-1ffea40c4a42bba612604c22f56cafc46f5fb4da.tar.gz
gentoo-1ffea40c4a42bba612604c22f56cafc46f5fb4da.tar.bz2
gentoo-1ffea40c4a42bba612604c22f56cafc46f5fb4da.zip
sys-libs/rpmatch-standalone: initial commit
This is a breakout library for rpmatch() which is not provided by the musl libc. See `man 3 rpmatch'. Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-libs/rpmatch-standalone/rpmatch-standalone-1.0.ebuild')
-rw-r--r--sys-libs/rpmatch-standalone/rpmatch-standalone-1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-libs/rpmatch-standalone/rpmatch-standalone-1.0.ebuild b/sys-libs/rpmatch-standalone/rpmatch-standalone-1.0.ebuild
new file mode 100644
index 000000000000..4881a46decc1
--- /dev/null
+++ b/sys-libs/rpmatch-standalone/rpmatch-standalone-1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Standalone rpmatch library for use with musl"
+HOMEPAGE="https://github.com/pullmoll/musl-rpmatch"
+SRC_URI="https://github.com/pullmoll/musl-rpmatch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+IUSE="static-libs"
+
+DEPEND="
+ !sys-libs/glibc
+ !sys-libs/uclibc"
+
+S="${WORKDIR}/musl-rpmatch-${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+
+ mkdir "${ED%/}"/usr/$(get_libdir)/pkgconfig/
+ cp "${S}"/musl-rpmatch.pc "${ED%/}"/usr/$(get_libdir)/pkgconfig/rpmatch-standalone.pc
+}