summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-libs/suacomp/suacomp-0.6.14.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-libs/suacomp/suacomp-0.6.14.ebuild')
-rw-r--r--sys-libs/suacomp/suacomp-0.6.14.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/sys-libs/suacomp/suacomp-0.6.14.ebuild b/sys-libs/suacomp/suacomp-0.6.14.ebuild
new file mode 100644
index 000000000000..9fe7f79cc5aa
--- /dev/null
+++ b/sys-libs/suacomp/suacomp-0.6.14.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="library wrapping the interix lib-c to make it less buggy"
+HOMEPAGE="http://suacomp.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BEER-WARE"
+SLOT="0"
+KEYWORDS="-* ~x86-interix"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND=""
+
+get_opts() {
+ local shlibc=
+ local stlibc=
+
+ for dir in /usr/lib /usr/lib/x86; do
+ [[ -f ${dir}/libc.a ]] && stlibc=${dir}/libc.a
+
+ for name in libc.so.5.2 libc.so.3.5; do
+ [[ -f ${dir}/${name} ]] && { shlibc=${dir}/${name}; break; }
+ done
+
+ [[ -f ${shlibc} && -f ${stlibc} ]] && break
+ done
+
+ echo "SHARED_LIBC=${shlibc} STATIC_LIBC=${stlibc}"
+}
+
+pkg_setup() {
+ if use debug; then
+ append-flags -D_DEBUG -D_DEBUG_TRACE
+ fi
+}
+
+src_prepare() {
+ [[ ${CHOST} == *-interix6* ]] && epatch "${FILESDIR}"/${P}-strtoll.patch
+}
+
+src_compile() {
+ emake all CC=$(tc-getCC) $(get_opts) CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install PREFIX="${EPREFIX}/usr" DESTDIR="${D}" $(get_opts) \
+ CFLAGS="${CFLAGS}" || die "emake install failed"
+}
+
+src_test() {
+ local v=
+
+ use debug && v="TEST_VERBOSE=1"
+ use debug && export SUACOMP_DEBUG_OUT=stderr
+
+ emake check $(get_opts) ${v} || die "emake check failed"
+}