summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-03-26 20:01:05 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-03-26 20:06:35 +0100
commitcf41aa8898f1b588be148e2dce4de3fddbdbe41d (patch)
tree5a3b52b9cd89895dc64520cc8b030104c7254c6e /sys-libs/talloc/talloc-2.1.14.ebuild
parentsys-libs/tevent: Removed old (diff)
downloadgentoo-cf41aa8898f1b588be148e2dce4de3fddbdbe41d.tar.gz
gentoo-cf41aa8898f1b588be148e2dce4de3fddbdbe41d.tar.bz2
gentoo-cf41aa8898f1b588be148e2dce4de3fddbdbe41d.zip
sys-libs/talloc: Removed old
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/talloc/talloc-2.1.14.ebuild')
-rw-r--r--sys-libs/talloc/talloc-2.1.14.ebuild89
1 files changed, 0 insertions, 89 deletions
diff --git a/sys-libs/talloc/talloc-2.1.14.ebuild b/sys-libs/talloc/talloc-2.1.14.ebuild
deleted file mode 100644
index f29bf4cb8a92..000000000000
--- a/sys-libs/talloc/talloc-2.1.14.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="threads"
-
-inherit waf-utils python-single-r1 multilib multilib-minimal
-
-DESCRIPTION="Samba talloc library"
-HOMEPAGE="https://talloc.samba.org/"
-SRC_URI="https://www.samba.org/ftp/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3 LGPL-3+ LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x64-solaris"
-IUSE="compat +python"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="!elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
- python? ( ${PYTHON_DEPS} )
- !!<sys-libs/talloc-2.0.5"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- dev-libs/libxslt
- ${PYTHON_DEPS}"
-
-WAF_BINARY="${S}/buildtools/bin/waf"
-
-RESTRICT="test"
-
-MULTILIB_WRAPPED_HEADERS=(
- # python goes only for native
- /usr/include/pytalloc.h
-)
-
-pkg_setup() {
- # try to turn off distcc and ccache for people that have a problem with it
- export DISTCC_DISABLE=1
- export CCACHE_DISABLE=1
-
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- # what would you expect of waf? i won't even waste time trying.
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- local extra_opts=(
- $(usex compat --enable-talloc-compat1 '')
- $(multilib_native_usex python '' --disable-python)
- )
- waf-utils_src_configure "${extra_opts[@]}"
-}
-
-multilib_src_compile() {
- waf-utils_src_compile
-}
-
-multilib_src_install() {
- waf-utils_src_install
-
- # waf is stupid, and no, we can't fix the build-system, since it's provided
- # as a brilliant binary blob thats decompressed on the fly
- if [[ ${CHOST} == *-darwin* ]] ; then
- install_name_tool \
- -id "${EPREFIX}"/usr/$(get_libdir)/libtalloc.2.dylib \
- "${ED}"/usr/$(get_libdir)/libtalloc.2.0.5.dylib || die
- if use python ; then
- install_name_tool \
- -id "${EPREFIX}"/usr/$(get_libdir)/libpytalloc-util.2.dylib \
- "${ED}"/usr/$(get_libdir)/libpytalloc-util.2.0.5.dylib || die
- install_name_tool \
- -change "${S}/bin/default/libtalloc.dylib" \
- "${EPREFIX}"/usr/$(get_libdir)/libtalloc.2.dylib \
- "${ED}"/usr/$(get_libdir)/libpytalloc-util.2.0.5.dylib || die
- install_name_tool \
- -change "${S}/bin/default/libtalloc.dylib" \
- "${EPREFIX}"/usr/$(get_libdir)/libtalloc.2.dylib \
- "${D}"$(python_get_sitedir)/talloc.bundle || die
- fi
- fi
-}