summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-02-26 18:36:14 +0100
committerFabian Groffen <grobian@gentoo.org>2017-02-26 20:06:16 +0100
commit796921c93f72e27bcfbdbea701238c1e9458b29c (patch)
tree2b24b08cfcb347c03930a1a1d63111c28a89f3ee /sys-libs/tapi/files/tapi-1.30-allow-all-clients.patch
parentprofiles: Mask dev-vcs/veracity for removal (diff)
downloadgentoo-796921c93f72e27bcfbdbea701238c1e9458b29c.tar.gz
gentoo-796921c93f72e27bcfbdbea701238c1e9458b29c.tar.bz2
gentoo-796921c93f72e27bcfbdbea701238c1e9458b29c.zip
sys-libs/tapi: initial ebuild by Michael Weiser, bug #609436
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-libs/tapi/files/tapi-1.30-allow-all-clients.patch')
-rw-r--r--sys-libs/tapi/files/tapi-1.30-allow-all-clients.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/sys-libs/tapi/files/tapi-1.30-allow-all-clients.patch b/sys-libs/tapi/files/tapi-1.30-allow-all-clients.patch
new file mode 100644
index 000000000000..98309132cf70
--- /dev/null
+++ b/sys-libs/tapi/files/tapi-1.30-allow-all-clients.patch
@@ -0,0 +1,17 @@
+libtapi is by default limited to be linked to binaries called ld only. When
+trying to link it into e.g. our ld64 we get:
+
+ld: cannot link directly with ${EPREFIX}/usr/lib/libtapi.dylib for architecture
+x86_64
+
+Drop that limitation in order to be able to use the library.
+
+--- libtapi-1.30/tools/libtapi/CMakeLists.txt.orig 2017-02-12 17:35:55.000000000 +0100
++++ libtapi-1.30/tools/libtapi/CMakeLists.txt 2017-02-12 17:36:17.000000000 +0100
+@@ -18,5 +18,5 @@
+
+ set_property(TARGET libtapi APPEND_STRING
+ PROPERTY
+- LINK_FLAGS " -current_version ${TAPI_VERSION_MAJOR}.${TAPI_VERSION_MINOR}.${TAPI_VERSION_PATCH} -compatibility_version 1 -allowable_client ld"
++ LINK_FLAGS " -current_version ${TAPI_VERSION_MAJOR}.${TAPI_VERSION_MINOR}.${TAPI_VERSION_PATCH} -compatibility_version 1"
+ )