summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-03-08 21:55:30 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-03-08 22:23:42 +0100
commitb00bd282eecc82bd2421e4a9b6c0d7f29cf699ff (patch)
treef6b39c8d2fe07f10cba401c1e0bc416c305ad696 /sys-libs/tevent/tevent-0.9.28.ebuild
parentsys-libs/talloc: Removed old. (diff)
downloadgentoo-b00bd282eecc82bd2421e4a9b6c0d7f29cf699ff.tar.gz
gentoo-b00bd282eecc82bd2421e4a9b6c0d7f29cf699ff.tar.bz2
gentoo-b00bd282eecc82bd2421e4a9b6c0d7f29cf699ff.zip
sys-libs/tevent: Bump to version 0.9.28
Package-Manager: portage-2.2.27 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/tevent/tevent-0.9.28.ebuild')
-rw-r--r--sys-libs/tevent/tevent-0.9.28.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-libs/tevent/tevent-0.9.28.ebuild b/sys-libs/tevent/tevent-0.9.28.ebuild
new file mode 100644
index 000000000000..5bbd329d57f7
--- /dev/null
+++ b/sys-libs/tevent/tevent-0.9.28.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="Samba tevent library"
+HOMEPAGE="http://tevent.samba.org/"
+SRC_URI="http://samba.org/ftp/tevent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="python"
+
+RDEPEND=">=sys-libs/talloc-2.1.5[${MULTILIB_USEDEP}]
+ python? ( ${PYTHON_DEPS} )"
+
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ ${PYTHON_DEPS}
+"
+# build system does not work with python3
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ waf-utils_src_configure \
+ $(multilib_native_usex python '' '--disable-python')
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ multilib_is_native_abi && use python && python_domodule tevent.py
+}