summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-27 12:38:46 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-04-27 18:11:15 -0400
commitbf60ab922b7e43493ea72a47a2f1095e24f86440 (patch)
tree4117fb0ab553d31be3d09655692348d989a2577d /sys-libs/uclibc/uclibc-0.9.33.9999.ebuild
parentsys-libs/fortify-headers: git-2->git-r3, EAPI=6 (diff)
downloadgentoo-bf60ab922b7e43493ea72a47a2f1095e24f86440.tar.gz
gentoo-bf60ab922b7e43493ea72a47a2f1095e24f86440.tar.bz2
gentoo-bf60ab922b7e43493ea72a47a2f1095e24f86440.zip
sys-libs/uclibc: git-2->git-r3, explicit EAPI=0
Also unified the live vs versioned ebuild logic. Package-Manager: Portage-2.3.31, Repoman-2.3.9 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'sys-libs/uclibc/uclibc-0.9.33.9999.ebuild')
-rw-r--r--sys-libs/uclibc/uclibc-0.9.33.9999.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/sys-libs/uclibc/uclibc-0.9.33.9999.ebuild b/sys-libs/uclibc/uclibc-0.9.33.9999.ebuild
index fbc8a60a1fc9..d55f0afff6da 100644
--- a/sys-libs/uclibc/uclibc-0.9.33.9999.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.33.9999.ebuild
@@ -1,11 +1,20 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=0
+
inherit eutils flag-o-matic multilib toolchain-funcs savedconfig
-if [[ ${PV} == *9999 ]] ; then
+
+MY_P=uClibc-${PV}
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://git.busybox.net/uClibc"
EGIT_BRANCH="0.9.33"
- EGIT_REPO_URI="git://git.busybox.net/uClibc"
- inherit git-2
+ inherit git-r3
+else
+ PATCH_VER=""
+ SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
+ ${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
+ KEYWORDS="-* ~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
fi
export CBUILD=${CBUILD:-${CHOST}}
@@ -16,15 +25,8 @@ if [[ ${CTARGET} == ${CHOST} ]] ; then
fi
fi
-MY_P=uClibc-${PV}
DESCRIPTION="C library for developing embedded Linux systems"
HOMEPAGE="https://www.uclibc.org/"
-if [[ ${PV} != *9999 ]] ; then
- PATCH_VER=""
- SRC_URI="https://uclibc.org/downloads/${MY_P}.tar.bz2
- ${PATCH_VER:+mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.bz2}"
- KEYWORDS="-* ~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
-fi
LICENSE="LGPL-2"
SLOT="0"
@@ -231,8 +233,8 @@ src_config() {
}
src_unpack() {
- if [[ ${PV} == *9999 ]] ; then
- git-2_src_unpack
+ if [[ ${PV} == *9999* ]] ; then
+ git-r3_src_unpack
else
unpack ${A}
fi