summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-04-12 20:15:31 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-04-12 20:15:31 -0400
commitdfbc591e232ca10978d22b8c5831321a1e20be4b (patch)
tree9b66b92f10391ee6044c2a345e0427ef7c64986d /sys-libs/uclibc
parentsys-libs/uclibc-ng: initial commit (diff)
downloadgentoo-dfbc591e232ca10978d22b8c5831321a1e20be4b.tar.gz
gentoo-dfbc591e232ca10978d22b8c5831321a1e20be4b.tar.bz2
gentoo-dfbc591e232ca10978d22b8c5831321a1e20be4b.zip
sys-libs/uclibc: block with sys-libs/uclibc-ng
Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-libs/uclibc')
-rw-r--r--sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild7
-rw-r--r--sys-libs/uclibc/uclibc-0.9.33.9999.ebuild7
-rw-r--r--sys-libs/uclibc/uclibc-9999.ebuild7
3 files changed, 18 insertions, 3 deletions
diff --git a/sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild b/sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild
index 6c3c0a09e801..be9d8e6897f9 100644
--- a/sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.33.2-r15.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -31,6 +31,11 @@ SLOT="0"
IUSE="debug hardened iconv ipv6 nptl rpc ssp uclibc-compat wordexp crosscompile_opts_headers-only"
RESTRICT="strip"
+# We cannot migrate between uclibc and uclibc-ng because as soon as portage
+# updates the ld.so sym link, the system breaks. Ideally this should be a
+# hard blocker, but EAPI=0 doesn't allow hard blockers.
+RDEPEND="!sys-libs/uclibc-ng"
+
S=${WORKDIR}/${MY_P}
is_crosscompile() {
diff --git a/sys-libs/uclibc/uclibc-0.9.33.9999.ebuild b/sys-libs/uclibc/uclibc-0.9.33.9999.ebuild
index a6dd21f56729..2d30cfe367e8 100644
--- a/sys-libs/uclibc/uclibc-0.9.33.9999.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.33.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -32,6 +32,11 @@ SLOT="0"
IUSE="debug hardened iconv ipv6 nptl rpc ssp uclibc-compat wordexp crosscompile_opts_headers-only"
RESTRICT="strip"
+# We cannot migrate between uclibc and uclibc-ng because as soon as portage
+# updates the ld.so sym link, the system breaks. Ideally this should be a
+# hard blocker, but EAPI=0 doesn't allow hard blockers.
+RDEPEND="!sys-libs/uclibc-ng"
+
S=${WORKDIR}/${MY_P}
is_crosscompile() {
diff --git a/sys-libs/uclibc/uclibc-9999.ebuild b/sys-libs/uclibc/uclibc-9999.ebuild
index 0d45e8364a25..5e54ad284ef9 100644
--- a/sys-libs/uclibc/uclibc-9999.ebuild
+++ b/sys-libs/uclibc/uclibc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -31,6 +31,11 @@ SLOT="0"
IUSE="debug hardened iconv ipv6 nptl rpc ssp uclibc-compat wordexp crosscompile_opts_headers-only"
RESTRICT="strip"
+# We cannot migrate between uclibc and uclibc-ng because as soon as portage
+# updates the ld.so sym link, the system breaks. Ideally this should be a
+# hard blocker, but EAPI=0 doesn't allow hard blockers.
+RDEPEND="!sys-libs/uclibc-ng"
+
S=${WORKDIR}/${MY_P}
is_crosscompile() {