summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-03-18 14:30:26 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-03-18 14:34:14 +0100
commitaea4c4a409b730eec427d6a800a1fdb4d4ebeb43 (patch)
tree219e6b01cfed3f34b4511e6e19390624d08a485b /sys-libs/uid_wrapper/uid_wrapper-1.2.1.ebuild
parentnet-libs/socket_wrapper: Removed old. (diff)
downloadgentoo-aea4c4a409b730eec427d6a800a1fdb4d4ebeb43.tar.gz
gentoo-aea4c4a409b730eec427d6a800a1fdb4d4ebeb43.tar.bz2
gentoo-aea4c4a409b730eec427d6a800a1fdb4d4ebeb43.zip
sys-libs/uid_wrapper: Bump to version 1.2.1
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/uid_wrapper/uid_wrapper-1.2.1.ebuild')
-rw-r--r--sys-libs/uid_wrapper/uid_wrapper-1.2.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-libs/uid_wrapper/uid_wrapper-1.2.1.ebuild b/sys-libs/uid_wrapper/uid_wrapper-1.2.1.ebuild
new file mode 100644
index 000000000000..8898e3137e9f
--- /dev/null
+++ b/sys-libs/uid_wrapper/uid_wrapper-1.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="A wrapper to fake privilege separation"
+HOMEPAGE="https://cwrap.org/uid_wrapper.html"
+SRC_URI="ftp://ftp.samba.org/pub/cwrap/${P}.tar.gz
+ https://ftp.samba.org/pub/cwrap/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+# Work around a problem with >=dev-util/cmake-3.3.0 (bug #558340)
+# Because of this we cannot use cmake-multilib_src_configure() here.
+multilib_src_configure() {
+ local mycmakeargs=( -DCMAKE_LIBRARY_PATH=/usr/$(get_libdir) )
+ cmake-utils_src_configure
+}