summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-01-28 07:18:16 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-01-28 07:23:46 -0500
commitadb9a35721e67faab0c5a75f31e38e8791e2f43b (patch)
treec1bb39ec667d7f1c2556bd31d33e43d9a46e73df /sys-libs/zlib
parentdev-python/mygpoclient: mark ALLARCHES (diff)
downloadgentoo-adb9a35721e67faab0c5a75f31e38e8791e2f43b.tar.gz
gentoo-adb9a35721e67faab0c5a75f31e38e8791e2f43b.tar.bz2
gentoo-adb9a35721e67faab0c5a75f31e38e8791e2f43b.zip
Revert "sys-libs/zlib: add patch to fix configure AR/RANLIB/NM detection"
Broken if NM is unset. Looks like a simple fix but let's not risk leaving zlib broken in stable (nor for too long, so reverting myself). This reverts commit bace9b48a6fe43bdf685f4aa81ca422130e2f807. Bug: https://bugs.gentoo.org/831628 Closes: https://bugs.gentoo.org/832202 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'sys-libs/zlib')
-rw-r--r--sys-libs/zlib/files/zlib-1.2.11-configure-fix-AR-RANLIB-NM-detection.patch79
-rw-r--r--sys-libs/zlib/zlib-1.2.11-r4.ebuild1
2 files changed, 0 insertions, 80 deletions
diff --git a/sys-libs/zlib/files/zlib-1.2.11-configure-fix-AR-RANLIB-NM-detection.patch b/sys-libs/zlib/files/zlib-1.2.11-configure-fix-AR-RANLIB-NM-detection.patch
deleted file mode 100644
index 68108a16fc3c..000000000000
--- a/sys-libs/zlib/files/zlib-1.2.11-configure-fix-AR-RANLIB-NM-detection.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-From 9ce4e2e190cd382407eb3029b7127e378a7c9627 Mon Sep 17 00:00:00 2001
-From: Adrian Ratiu <adrian.ratiu@collabora.com>
-Date: Mon, 17 Jan 2022 10:49:58 +0200
-Subject: [PATCH] configure: fix AR/RANLIB/NM detection
-
-Taken from zlib-devel ML:
-https://madler.net/pipermail/zlib-devel_madler.net/2022-January/003322.html
-
-Bug: https://bugs.gentoo.org/831628
-
-Scenarios where ${CROSS_PREFIX}ar & co are set but not desired
-are possible, for example in ChromiumOS we use the GNU binutils
-tools & GCC to build glibc but LLVM/Clang is used for the rest
-of the system.
-
-This allows $AR/$RANLIB/$NM to override default CROSS_PREFIX
-tools so they can be set to llvm-ar/ranlib/nm.
-
-Suggested-by: Manoj Gupta <manojgupta@chromium.org>
-Signed-off-by: Adrian Ratiu <adrian.ratiu@collabora.com>
----
- configure | 38 ++++++++++++++++++++++----------------
- 1 file changed, 22 insertions(+), 16 deletions(-)
-
-diff --git a/configure b/configure
-index e974d1f..180cf09 100755
---- a/configure
-+++ b/configure
-@@ -46,25 +46,31 @@ VER2=`sed -n -e '/VERSION "/s/.*"\([0-9]*\\.[0-9]*\)\\..*/\1/p' < ${SRCDIR}zlib.
- VER1=`sed -n -e '/VERSION "/s/.*"\([0-9]*\)\\..*/\1/p' < ${SRCDIR}zlib.h`
-
- # establish commands for library building
--if "${CROSS_PREFIX}ar" --version >/dev/null 2>/dev/null || test $? -lt 126; then
-- AR=${AR-"${CROSS_PREFIX}ar"}
-- test -n "${CROSS_PREFIX}" && echo Using ${AR} | tee -a configure.log
--else
-- AR=${AR-"ar"}
-- test -n "${CROSS_PREFIX}" && echo Using ${AR} | tee -a configure.log
-+if [ -z "AR" ] ; then
-+ if "${CROSS_PREFIX}ar" --version >/dev/null 2>/dev/null || test $? -lt 126; then
-+ AR=${AR-"${CROSS_PREFIX}ar"}
-+ test -n "${CROSS_PREFIX}" && echo Using ${AR} | tee -a configure.log
-+ else
-+ AR="ar"
-+ test -n "${CROSS_PREFIX}" && echo Using ${AR} | tee -a configure.log
-+ fi
- fi
- ARFLAGS=${ARFLAGS-"rc"}
--if "${CROSS_PREFIX}ranlib" --version >/dev/null 2>/dev/null || test $? -lt 126; then
-- RANLIB=${RANLIB-"${CROSS_PREFIX}ranlib"}
-- test -n "${CROSS_PREFIX}" && echo Using ${RANLIB} | tee -a configure.log
--else
-- RANLIB=${RANLIB-"ranlib"}
-+if [ -z "RANLIB" ] ; then
-+ if "${CROSS_PREFIX}ranlib" --version >/dev/null 2>/dev/null || test $? -lt 126; then
-+ RANLIB=${RANLIB-"${CROSS_PREFIX}ranlib"}
-+ test -n "${CROSS_PREFIX}" && echo Using ${RANLIB} | tee -a configure.log
-+ else
-+ RANLIB="ranlib"
-+ fi
- fi
--if "${CROSS_PREFIX}nm" --version >/dev/null 2>/dev/null || test $? -lt 126; then
-- NM=${NM-"${CROSS_PREFIX}nm"}
-- test -n "${CROSS_PREFIX}" && echo Using ${NM} | tee -a configure.log
--else
-- NM=${NM-"nm"}
-+if [ -z "$NM" ] ; then
-+ if "${CROSS_PREFIX}nm" --version >/dev/null 2>/dev/null || test $? -lt 126; then
-+ NM=${"${CROSS_PREFIX}nm"}
-+ test -n "${CROSS_PREFIX}" && echo Using ${NM} | tee -a configure.log
-+ else
-+ NM="nm"
-+ fi
- fi
-
- # set defaults before processing command line options
---
-2.34.1
-
diff --git a/sys-libs/zlib/zlib-1.2.11-r4.ebuild b/sys-libs/zlib/zlib-1.2.11-r4.ebuild
index 3b8524a12c6e..bc2fe9834ee2 100644
--- a/sys-libs/zlib/zlib-1.2.11-r4.ebuild
+++ b/sys-libs/zlib/zlib-1.2.11-r4.ebuild
@@ -34,7 +34,6 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-1.2.11-fix-deflateParams-usage.patch
"${FILESDIR}"/${PN}-1.2.11-minizip-drop-crypt-header.patch #658536
- "${FILESDIR}"/${PN}-1.2.11-configure-fix-AR-RANLIB-NM-detection.patch #831628
)
src_prepare() {