summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-20 18:21:01 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-20 18:32:52 +0200
commit029b788f8d23753ff6d69610d44dc69586355602 (patch)
tree839fa2430723806c088f9e52d0679b89663ad8b3 /sys-libs
parentsys-libs/llvm-libunwind: Port to py3.9 (diff)
downloadgentoo-029b788f8d23753ff6d69610d44dc69586355602.tar.gz
gentoo-029b788f8d23753ff6d69610d44dc69586355602.tar.bz2
gentoo-029b788f8d23753ff6d69610d44dc69586355602.zip
sys-libs/libcxxabi: Apply patches in WORKDIR in 10.0.1+
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxxabi/libcxxabi-10.0.1.9999.ebuild7
-rw-r--r--sys-libs/libcxxabi/libcxxabi-10.0.1_rc1.ebuild7
-rw-r--r--sys-libs/libcxxabi/libcxxabi-11.0.0.9999.ebuild7
3 files changed, 21 insertions, 0 deletions
diff --git a/sys-libs/libcxxabi/libcxxabi-10.0.1.9999.ebuild b/sys-libs/libcxxabi/libcxxabi-10.0.1.9999.ebuild
index de7c2b4fb58b..9a0258061955 100644
--- a/sys-libs/libcxxabi/libcxxabi-10.0.1.9999.ebuild
+++ b/sys-libs/libcxxabi/libcxxabi-10.0.1.9999.ebuild
@@ -44,6 +44,13 @@ pkg_setup() {
use test && python-any-r1_pkg_setup
}
+src_prepare() {
+ # cmake eclasses suck by forcing ${S} here
+ CMAKE_USE_DIR=${S} \
+ S=${WORKDIR} \
+ cmake-utils_src_prepare
+}
+
multilib_src_configure() {
# link against compiler-rt instead of libgcc if we are using clang with libunwind
local want_compiler_rt=OFF
diff --git a/sys-libs/libcxxabi/libcxxabi-10.0.1_rc1.ebuild b/sys-libs/libcxxabi/libcxxabi-10.0.1_rc1.ebuild
index de7c2b4fb58b..9a0258061955 100644
--- a/sys-libs/libcxxabi/libcxxabi-10.0.1_rc1.ebuild
+++ b/sys-libs/libcxxabi/libcxxabi-10.0.1_rc1.ebuild
@@ -44,6 +44,13 @@ pkg_setup() {
use test && python-any-r1_pkg_setup
}
+src_prepare() {
+ # cmake eclasses suck by forcing ${S} here
+ CMAKE_USE_DIR=${S} \
+ S=${WORKDIR} \
+ cmake-utils_src_prepare
+}
+
multilib_src_configure() {
# link against compiler-rt instead of libgcc if we are using clang with libunwind
local want_compiler_rt=OFF
diff --git a/sys-libs/libcxxabi/libcxxabi-11.0.0.9999.ebuild b/sys-libs/libcxxabi/libcxxabi-11.0.0.9999.ebuild
index 7946dde2bb22..5fb1704b2c15 100644
--- a/sys-libs/libcxxabi/libcxxabi-11.0.0.9999.ebuild
+++ b/sys-libs/libcxxabi/libcxxabi-11.0.0.9999.ebuild
@@ -44,6 +44,13 @@ pkg_setup() {
use test && python-any-r1_pkg_setup
}
+src_prepare() {
+ # cmake eclasses suck by forcing ${S} here
+ CMAKE_USE_DIR=${S} \
+ S=${WORKDIR} \
+ cmake-utils_src_prepare
+}
+
multilib_src_configure() {
# link against compiler-rt instead of libgcc if we are using clang with libunwind
local want_compiler_rt=OFF