summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-12-21 19:00:30 +0100
committerMichał Górny <mgorny@gentoo.org>2017-12-21 22:00:59 +0100
commit06bc1b3b39b680fa0621dd7eda58c5b8c1eecb2e (patch)
tree4707d5660990e1525d60feb1e031e093ff040a74 /sys-libs
parentsys-libs/compiler-rt-sanitizers: Remove live ebuild for obsolete 5.0 branch (diff)
downloadgentoo-06bc1b3b39b680fa0621dd7eda58c5b8c1eecb2e.tar.gz
gentoo-06bc1b3b39b680fa0621dd7eda58c5b8c1eecb2e.tar.bz2
gentoo-06bc1b3b39b680fa0621dd7eda58c5b8c1eecb2e.zip
sys-libs/llvm-libunwind: Remove live ebuild for obsolete 5.0 branch
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-5.0.9999.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-5.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-5.0.9999.ebuild
deleted file mode 100644
index fc8c13fc44bf..000000000000
--- a/sys-libs/llvm-libunwind/llvm-libunwind-5.0.9999.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-# (needed due to CMAKE_BUILD_TYPE != Gentoo)
-CMAKE_MIN_VERSION=3.7.0-r1
-inherit cmake-multilib git-r3 llvm
-
-DESCRIPTION="C++ runtime stack unwinder from LLVM"
-HOMEPAGE="https://github.com/llvm-mirror/libunwind"
-SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/libunwind.git
- https://github.com/llvm-mirror/libunwind.git"
-EGIT_BRANCH="release_50"
-
-LICENSE="|| ( UoI-NCSA MIT )"
-SLOT="0"
-KEYWORDS=""
-IUSE="debug +static-libs"
-
-RDEPEND="!sys-libs/libunwind"
-# LLVM 4 required for llvm-config --cmakedir
-DEPEND=">=sys-devel/llvm-4"
-
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
-multilib_src_configure() {
- local libdir=$(get_libdir)
-
- local mycmakeargs=(
- -DLLVM_LIBDIR_SUFFIX=${libdir#lib}
- -DLIBUNWIND_ENABLE_ASSERTIONS=$(usex debug)
- -DLIBUNWIND_ENABLE_STATIC=$(usex static-libs)
- )
-
- cmake-utils_src_configure
-}
-
-multilib_src_install() {
- cmake-utils_src_install
-
- # install headers like sys-libs/libunwind
- doheader "${S}"/include/*.h
-}