summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-08-04 00:45:06 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-08-04 00:45:06 +0200
commit124591d3e0c9579953b81ad8706b233177f0e95b (patch)
tree409839cb7a6402eafd224ad71673873ae330953d /sys-libs
parentsys-libs/glibc: Version bump, untested, without keywords (diff)
downloadgentoo-124591d3e0c9579953b81ad8706b233177f0e95b.tar.gz
gentoo-124591d3e0c9579953b81ad8706b233177f0e95b.tar.bz2
gentoo-124591d3e0c9579953b81ad8706b233177f0e95b.zip
sys-libs/glibc: Complete compile-locale handling, hopefully
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.30.ebuild6
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild6
2 files changed, 12 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-2.30.ebuild b/sys-libs/glibc/glibc-2.30.ebuild
index 6743802aea09..2d1e13c28ace 100644
--- a/sys-libs/glibc/glibc-2.30.ebuild
+++ b/sys-libs/glibc/glibc-2.30.ebuild
@@ -1142,6 +1142,9 @@ run_locale_gen() {
# if the host locales.gen contains no entries, we'll install everything
local root="$1"
local locale_list="${root}/etc/locale.gen"
+
+ pushd "${ED}"/$(get_libdir)
+
if [[ -z $(locale-gen --list --config "${locale_list}") ]] ; then
ewarn "Generating all locales; edit /etc/locale.gen to save time/space"
locale_list="${root}/usr/share/i18n/SUPPORTED"
@@ -1149,6 +1152,8 @@ run_locale_gen() {
locale-gen --jobs $(makeopts_jobs) --config "${locale_list}" \
--destdir "${root}"
+
+ popd
}
glibc_do_src_install() {
@@ -1333,6 +1338,7 @@ glibc_do_src_install() {
# Generate all locales if this is a native build as locale generation
if use compile-locales && ! is_crosscompile ; then
run_locale_gen "${ED}"
+ sed -e 's:COMPILED_LOCALES="":COMPILED_LOCALES="1":' -i "${ED}"/usr/sbin/locale-gen || die
fi
}
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 0b6964c6a3b4..4d0a9edb57a0 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1142,6 +1142,9 @@ run_locale_gen() {
# if the host locales.gen contains no entries, we'll install everything
local root="$1"
local locale_list="${root}/etc/locale.gen"
+
+ pushd "${ED}"/$(get_libdir)
+
if [[ -z $(locale-gen --list --config "${locale_list}") ]] ; then
ewarn "Generating all locales; edit /etc/locale.gen to save time/space"
locale_list="${root}/usr/share/i18n/SUPPORTED"
@@ -1149,6 +1152,8 @@ run_locale_gen() {
locale-gen --jobs $(makeopts_jobs) --config "${locale_list}" \
--destdir "${root}"
+
+ popd
}
glibc_do_src_install() {
@@ -1333,6 +1338,7 @@ glibc_do_src_install() {
# Generate all locales if this is a native build as locale generation
if use compile-locales && ! is_crosscompile ; then
run_locale_gen "${ED}"
+ sed -e 's:COMPILED_LOCALES="":COMPILED_LOCALES="1":' -i "${ED}"/usr/sbin/locale-gen || die
fi
}