summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-13 10:35:52 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-20 18:53:45 +0300
commit21ef29dd0b7872c5b61cf8f86200e899e3f42cf2 (patch)
tree4eca29cc2aa80a0bdb26243aced8bb57b626dbfb /sys-libs
parentwww-apache/mod_gnutls: use python_has_version (diff)
downloadgentoo-21ef29dd0b7872c5b61cf8f86200e899e3f42cf2.tar.gz
gentoo-21ef29dd0b7872c5b61cf8f86200e899e3f42cf2.tar.bz2
gentoo-21ef29dd0b7872c5b61cf8f86200e899e3f42cf2.zip
sys-libs/libxcrypt: use python_has_version
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libxcrypt/libxcrypt-4.4.20.ebuild2
-rw-r--r--sys-libs/libxcrypt/libxcrypt-4.4.27.ebuild2
-rw-r--r--sys-libs/libxcrypt/libxcrypt-4.4.28-r1.ebuild2
-rw-r--r--sys-libs/libxcrypt/libxcrypt-4.4.28.ebuild2
4 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.20.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.20.ebuild
index 9d57697c9416..b918f9efda8d 100644
--- a/sys-libs/libxcrypt/libxcrypt-4.4.20.ebuild
+++ b/sys-libs/libxcrypt/libxcrypt-4.4.20.ebuild
@@ -34,7 +34,7 @@ BDEPEND="dev-lang/perl
test? ( $(python_gen_any_dep 'dev-python/passlib[${PYTHON_USEDEP}]') )"
python_check_deps() {
- has_version -b "dev-python/passlib[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/passlib[${PYTHON_USEDEP}]"
}
pkg_setup() {
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.27.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.27.ebuild
index c9559428437e..60500e99a483 100644
--- a/sys-libs/libxcrypt/libxcrypt-4.4.27.ebuild
+++ b/sys-libs/libxcrypt/libxcrypt-4.4.27.ebuild
@@ -38,7 +38,7 @@ BDEPEND="dev-lang/perl
test? ( $(python_gen_any_dep 'dev-python/passlib[${PYTHON_USEDEP}]') )"
python_check_deps() {
- has_version -b "dev-python/passlib[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/passlib[${PYTHON_USEDEP}]"
}
pkg_pretend() {
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.28-r1.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.28-r1.ebuild
index a725dffed1ed..b43b4ada2480 100644
--- a/sys-libs/libxcrypt/libxcrypt-4.4.28-r1.ebuild
+++ b/sys-libs/libxcrypt/libxcrypt-4.4.28-r1.ebuild
@@ -50,7 +50,7 @@ BDEPEND="dev-lang/perl
test? ( $(python_gen_any_dep 'dev-python/passlib[${PYTHON_USEDEP}]') )"
python_check_deps() {
- has_version -b "dev-python/passlib[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/passlib[${PYTHON_USEDEP}]"
}
pkg_pretend() {
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.28.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.28.ebuild
index 50aec10c1952..0a364e88a43d 100644
--- a/sys-libs/libxcrypt/libxcrypt-4.4.28.ebuild
+++ b/sys-libs/libxcrypt/libxcrypt-4.4.28.ebuild
@@ -50,7 +50,7 @@ BDEPEND="dev-lang/perl
test? ( $(python_gen_any_dep 'dev-python/passlib[${PYTHON_USEDEP}]') )"
python_check_deps() {
- has_version -b "dev-python/passlib[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/passlib[${PYTHON_USEDEP}]"
}
pkg_pretend() {