summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-21 10:11:42 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-21 10:23:20 +0200
commit2a7f33b4ea73c1d355438653529b633ec2240f9a (patch)
tree7cccf50d34ed86c8d2a5475c6b6449510d670733 /sys-libs
parentsys-libs/libcxxabi: Force matchling LLVM/Clang version (diff)
downloadgentoo-2a7f33b4ea73c1d355438653529b633ec2240f9a.tar.gz
gentoo-2a7f33b4ea73c1d355438653529b633ec2240f9a.tar.bz2
gentoo-2a7f33b4ea73c1d355438653529b633ec2240f9a.zip
sys-libs/libcxx: Force matchling LLVM/Clang version
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxx/libcxx-15.0.1.9999.ebuild15
-rw-r--r--sys-libs/libcxx/libcxx-15.0.1.ebuild15
-rw-r--r--sys-libs/libcxx/libcxx-16.0.0.9999.ebuild15
-rw-r--r--sys-libs/libcxx/libcxx-16.0.0_pre20220918.ebuild15
4 files changed, 16 insertions, 44 deletions
diff --git a/sys-libs/libcxx/libcxx-15.0.1.9999.ebuild b/sys-libs/libcxx/libcxx-15.0.1.9999.ebuild
index 07049e01ed34..28c4cca66346 100644
--- a/sys-libs/libcxx/libcxx-15.0.1.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-15.0.1.9999.ebuild
@@ -23,16 +23,14 @@ RDEPEND="
)
!libcxxabi? ( >=sys-devel/gcc-4.7:=[cxx] )
"
-# llvm-6 for new lit options
-# clang-3.9.0 installs necessary target symlinks unconditionally
-# which removes the need for MULTILIB_USEDEP
+LLVM_MAX_SLOT=${PV%%.*}
DEPEND="
${RDEPEND}
- >=sys-devel/llvm-6
+ sys-devel/llvm:${LLVM_MAX_SLOT}
"
BDEPEND="
clang? (
- sys-devel/clang
+ sys-devel/clang:${LLVM_MAX_SLOT}
)
!test? (
${PYTHON_DEPS}
@@ -91,9 +89,7 @@ src_configure() {
}
multilib_src_configure() {
- if use clang && ! tc-is-clang; then
- # Only do this conditionally to allow overriding with
- # e.g. CC=clang-13 in case of breakage
+ if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
strip-unsupported-flags
@@ -139,9 +135,6 @@ multilib_src_configure() {
)
if use test; then
- local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
- [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
-
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="$(get_lit_flags)"
diff --git a/sys-libs/libcxx/libcxx-15.0.1.ebuild b/sys-libs/libcxx/libcxx-15.0.1.ebuild
index 838aac063945..79e6aec88593 100644
--- a/sys-libs/libcxx/libcxx-15.0.1.ebuild
+++ b/sys-libs/libcxx/libcxx-15.0.1.ebuild
@@ -23,16 +23,14 @@ RDEPEND="
)
!libcxxabi? ( >=sys-devel/gcc-4.7:=[cxx] )
"
-# llvm-6 for new lit options
-# clang-3.9.0 installs necessary target symlinks unconditionally
-# which removes the need for MULTILIB_USEDEP
+LLVM_MAX_SLOT=${PV%%.*}
DEPEND="
${RDEPEND}
- >=sys-devel/llvm-6
+ sys-devel/llvm:${LLVM_MAX_SLOT}
"
BDEPEND="
clang? (
- sys-devel/clang
+ sys-devel/clang:${LLVM_MAX_SLOT}
)
!test? (
${PYTHON_DEPS}
@@ -91,9 +89,7 @@ src_configure() {
}
multilib_src_configure() {
- if use clang && ! tc-is-clang; then
- # Only do this conditionally to allow overriding with
- # e.g. CC=clang-13 in case of breakage
+ if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
strip-unsupported-flags
@@ -139,9 +135,6 @@ multilib_src_configure() {
)
if use test; then
- local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
- [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
-
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="$(get_lit_flags)"
diff --git a/sys-libs/libcxx/libcxx-16.0.0.9999.ebuild b/sys-libs/libcxx/libcxx-16.0.0.9999.ebuild
index 07049e01ed34..28c4cca66346 100644
--- a/sys-libs/libcxx/libcxx-16.0.0.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-16.0.0.9999.ebuild
@@ -23,16 +23,14 @@ RDEPEND="
)
!libcxxabi? ( >=sys-devel/gcc-4.7:=[cxx] )
"
-# llvm-6 for new lit options
-# clang-3.9.0 installs necessary target symlinks unconditionally
-# which removes the need for MULTILIB_USEDEP
+LLVM_MAX_SLOT=${PV%%.*}
DEPEND="
${RDEPEND}
- >=sys-devel/llvm-6
+ sys-devel/llvm:${LLVM_MAX_SLOT}
"
BDEPEND="
clang? (
- sys-devel/clang
+ sys-devel/clang:${LLVM_MAX_SLOT}
)
!test? (
${PYTHON_DEPS}
@@ -91,9 +89,7 @@ src_configure() {
}
multilib_src_configure() {
- if use clang && ! tc-is-clang; then
- # Only do this conditionally to allow overriding with
- # e.g. CC=clang-13 in case of breakage
+ if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
strip-unsupported-flags
@@ -139,9 +135,6 @@ multilib_src_configure() {
)
if use test; then
- local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
- [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
-
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="$(get_lit_flags)"
diff --git a/sys-libs/libcxx/libcxx-16.0.0_pre20220918.ebuild b/sys-libs/libcxx/libcxx-16.0.0_pre20220918.ebuild
index 07049e01ed34..28c4cca66346 100644
--- a/sys-libs/libcxx/libcxx-16.0.0_pre20220918.ebuild
+++ b/sys-libs/libcxx/libcxx-16.0.0_pre20220918.ebuild
@@ -23,16 +23,14 @@ RDEPEND="
)
!libcxxabi? ( >=sys-devel/gcc-4.7:=[cxx] )
"
-# llvm-6 for new lit options
-# clang-3.9.0 installs necessary target symlinks unconditionally
-# which removes the need for MULTILIB_USEDEP
+LLVM_MAX_SLOT=${PV%%.*}
DEPEND="
${RDEPEND}
- >=sys-devel/llvm-6
+ sys-devel/llvm:${LLVM_MAX_SLOT}
"
BDEPEND="
clang? (
- sys-devel/clang
+ sys-devel/clang:${LLVM_MAX_SLOT}
)
!test? (
${PYTHON_DEPS}
@@ -91,9 +89,7 @@ src_configure() {
}
multilib_src_configure() {
- if use clang && ! tc-is-clang; then
- # Only do this conditionally to allow overriding with
- # e.g. CC=clang-13 in case of breakage
+ if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
strip-unsupported-flags
@@ -139,9 +135,6 @@ multilib_src_configure() {
)
if use test; then
- local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
- [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
-
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="$(get_lit_flags)"