summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-06-16 09:33:14 -0500
committerMatthias Maier <tamiko@gentoo.org>2017-06-16 09:33:14 -0500
commit3c17dc821398caea38e15db5e0ae8788b88f2f80 (patch)
tree6691a51e0957b32258c41b729796235e10a984d7 /sys-libs
parentapp-emulation/qemu: use tc-enables-pie instead of gcc-specs-pie (diff)
downloadgentoo-3c17dc821398caea38e15db5e0ae8788b88f2f80.tar.gz
gentoo-3c17dc821398caea38e15db5e0ae8788b88f2f80.tar.bz2
gentoo-3c17dc821398caea38e15db5e0ae8788b88f2f80.zip
sys-libs/glibc: use tc-enables-pie instead of gcc-specs-pie
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.17.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.18-r1.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.19-r1.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.20-r2.ebuild2
-rw-r--r--sys-libs/glibc/glibc-2.21-r2.ebuild2
5 files changed, 5 insertions, 5 deletions
diff --git a/sys-libs/glibc/glibc-2.17.ebuild b/sys-libs/glibc/glibc-2.17.ebuild
index 11f180adc572..a0d0cd113b83 100644
--- a/sys-libs/glibc/glibc-2.17.ebuild
+++ b/sys-libs/glibc/glibc-2.17.ebuild
@@ -111,7 +111,7 @@ src_unpack() {
if use hardened ; then
cd "${S}"
einfo "Patching to get working PIE binaries on PIE (hardened) platforms"
- gcc-specs-pie && epatch "${FILESDIR}"/2.17/glibc-2.17-hardened-pie.patch
+ tc-enables-pie && epatch "${FILESDIR}"/2.17/glibc-2.17-hardened-pie.patch
epatch "${FILESDIR}"/2.10/glibc-2.10-hardened-configure-picdefault.patch
epatch "${FILESDIR}"/2.10/glibc-2.10-hardened-inittls-nosysenter.patch
diff --git a/sys-libs/glibc/glibc-2.18-r1.ebuild b/sys-libs/glibc/glibc-2.18-r1.ebuild
index 71ed7aea497a..a9c0bfc2c2b7 100644
--- a/sys-libs/glibc/glibc-2.18-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.18-r1.ebuild
@@ -111,7 +111,7 @@ src_unpack() {
if use hardened ; then
cd "${S}"
einfo "Patching to get working PIE binaries on PIE (hardened) platforms"
- gcc-specs-pie && epatch "${FILESDIR}"/2.17/glibc-2.17-hardened-pie.patch
+ tc-enables-pie && epatch "${FILESDIR}"/2.17/glibc-2.17-hardened-pie.patch
epatch "${FILESDIR}"/2.10/glibc-2.10-hardened-configure-picdefault.patch
epatch "${FILESDIR}"/2.18/glibc-2.18-hardened-inittls-nosysenter.patch
diff --git a/sys-libs/glibc/glibc-2.19-r1.ebuild b/sys-libs/glibc/glibc-2.19-r1.ebuild
index f86bb021c504..8860850c0224 100644
--- a/sys-libs/glibc/glibc-2.19-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.19-r1.ebuild
@@ -112,7 +112,7 @@ src_unpack() {
if use hardened ; then
einfo "Patching to get working PIE binaries on PIE (hardened) platforms"
- gcc-specs-pie && epatch "${FILESDIR}"/2.17/glibc-2.17-hardened-pie.patch
+ tc-enables-pie && epatch "${FILESDIR}"/2.17/glibc-2.17-hardened-pie.patch
epatch "${FILESDIR}"/2.19/glibc-2.19-hardened-configure-picdefault.patch
epatch "${FILESDIR}"/2.18/glibc-2.18-hardened-inittls-nosysenter.patch
diff --git a/sys-libs/glibc/glibc-2.20-r2.ebuild b/sys-libs/glibc/glibc-2.20-r2.ebuild
index d0956e2eb60d..04363835f616 100644
--- a/sys-libs/glibc/glibc-2.20-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.20-r2.ebuild
@@ -116,7 +116,7 @@ src_prepare() {
if use hardened ; then
einfo "Patching to get working PIE binaries on PIE (hardened) platforms"
- gcc-specs-pie && epatch "${FILESDIR}"/2.17/glibc-2.17-hardened-pie.patch
+ tc-enables-pie && epatch "${FILESDIR}"/2.17/glibc-2.17-hardened-pie.patch
epatch "${FILESDIR}"/2.20/glibc-2.20-hardened-inittls-nosysenter.patch
# We don't enable these for non-hardened as the output is very terse --
diff --git a/sys-libs/glibc/glibc-2.21-r2.ebuild b/sys-libs/glibc/glibc-2.21-r2.ebuild
index ec75650f0676..9216657a9703 100644
--- a/sys-libs/glibc/glibc-2.21-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.21-r2.ebuild
@@ -116,7 +116,7 @@ src_prepare() {
if use hardened ; then
einfo "Patching to get working PIE binaries on PIE (hardened) platforms"
- gcc-specs-pie && epatch "${FILESDIR}"/2.17/glibc-2.17-hardened-pie.patch
+ tc-enables-pie && epatch "${FILESDIR}"/2.17/glibc-2.17-hardened-pie.patch
epatch "${FILESDIR}"/2.20/glibc-2.20-hardened-inittls-nosysenter.patch
# We don't enable these for non-hardened as the output is very terse --