summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-17 10:38:41 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-25 19:26:59 +0200
commit3f90f9953de87db24b84a0bfb32aaa2f78c99776 (patch)
treec68260a0652a0637480b8996bc127d6d3298fe97 /sys-libs
parentdev-java/jackson-2.8.5: removed obsolete (also cve) (diff)
downloadgentoo-3f90f9953de87db24b84a0bfb32aaa2f78c99776.tar.gz
gentoo-3f90f9953de87db24b84a0bfb32aaa2f78c99776.tar.bz2
gentoo-3f90f9953de87db24b84a0bfb32aaa2f78c99776.zip
sys-libs/netbsd-csu: Force testing with sys-devel/clang
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/netbsd-csu/netbsd-csu-7.1.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/sys-libs/netbsd-csu/netbsd-csu-7.1.ebuild b/sys-libs/netbsd-csu/netbsd-csu-7.1.ebuild
index bacdd60d24fa..c3b117bb5771 100644
--- a/sys-libs/netbsd-csu/netbsd-csu-7.1.ebuild
+++ b/sys-libs/netbsd-csu/netbsd-csu-7.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,9 +12,11 @@ SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.xz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
-DEPEND="app-arch/xz-utils"
+DEPEND="app-arch/xz-utils
+ test? ( sys-devel/clang )"
S=${WORKDIR}/${P}/lib/csu
@@ -60,9 +62,14 @@ multilib_src_compile() {
}
multilib_src_test() {
+ # TODO: fix gcc support
+ local -x CC=${CHOST}-clang
+ local -x CXX=${CHOST}-clang++
+ strip-unsupported-flags
+
local cc=(
# -B sets prefix for internal gcc/clang file lookup
- $(tc-getCC) -B"${BUILD_DIR}"
+ "${CC}" -B"${BUILD_DIR}"
)
# 1. figure out the correct location for crt* files