summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-20 23:08:41 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-23 20:30:54 +0200
commit43533d106cbea73706fa3b6e533cf373c1db534d (patch)
tree9a5f6ebd0c6a5bca8a828bac5e6dc26059f15d52 /sys-libs
parentsys-libs/libcxxabi: Dedupe with new eclass code (diff)
downloadgentoo-43533d106cbea73706fa3b6e533cf373c1db534d.tar.gz
gentoo-43533d106cbea73706fa3b6e533cf373c1db534d.tar.bz2
gentoo-43533d106cbea73706fa3b6e533cf373c1db534d.zip
sys-libs/libcxx: Dedupe with new eclass code
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxx/libcxx-10.0.1.9999.ebuild15
-rw-r--r--sys-libs/libcxx/libcxx-10.0.1_rc1.ebuild15
-rw-r--r--sys-libs/libcxx/libcxx-11.0.0.9999.ebuild15
3 files changed, 9 insertions, 36 deletions
diff --git a/sys-libs/libcxx/libcxx-10.0.1.9999.ebuild b/sys-libs/libcxx/libcxx-10.0.1.9999.ebuild
index 055385df1c68..f96a537e3541 100644
--- a/sys-libs/libcxx/libcxx-10.0.1.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-10.0.1.9999.ebuild
@@ -5,8 +5,7 @@ EAPI=7
CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{6..9} )
-inherit cmake-multilib llvm llvm.org multiprocessing python-any-r1 \
- toolchain-funcs
+inherit cmake-multilib llvm llvm.org python-any-r1 toolchain-funcs
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
HOMEPAGE="https://libcxx.llvm.org/"
@@ -34,9 +33,6 @@ BDEPEND="
DOCS=( CREDITS.TXT )
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
python_check_deps() {
has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
@@ -58,10 +54,7 @@ src_prepare() {
# out-of-tree build.
eapply "${FILESDIR}/${PN}-3.9-cmake-link-flags.patch"
- # cmake eclasses suck by forcing ${S} here
- CMAKE_USE_DIR=${S} \
- S=${WORKDIR} \
- cmake_src_prepare
+ llvm.org_src_prepare
}
test_compiler() {
@@ -132,13 +125,11 @@ multilib_src_configure() {
if use test; then
local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
- local jobs=${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}
-
[[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="-vv;-j;${jobs};--param=cxx_under_test=${clang_path}"
+ -DLLVM_LIT_ARGS="$(get_lit_flags);--param=cxx_under_test=${clang_path}"
)
fi
cmake_src_configure
diff --git a/sys-libs/libcxx/libcxx-10.0.1_rc1.ebuild b/sys-libs/libcxx/libcxx-10.0.1_rc1.ebuild
index 055385df1c68..f96a537e3541 100644
--- a/sys-libs/libcxx/libcxx-10.0.1_rc1.ebuild
+++ b/sys-libs/libcxx/libcxx-10.0.1_rc1.ebuild
@@ -5,8 +5,7 @@ EAPI=7
CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{6..9} )
-inherit cmake-multilib llvm llvm.org multiprocessing python-any-r1 \
- toolchain-funcs
+inherit cmake-multilib llvm llvm.org python-any-r1 toolchain-funcs
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
HOMEPAGE="https://libcxx.llvm.org/"
@@ -34,9 +33,6 @@ BDEPEND="
DOCS=( CREDITS.TXT )
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
python_check_deps() {
has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
@@ -58,10 +54,7 @@ src_prepare() {
# out-of-tree build.
eapply "${FILESDIR}/${PN}-3.9-cmake-link-flags.patch"
- # cmake eclasses suck by forcing ${S} here
- CMAKE_USE_DIR=${S} \
- S=${WORKDIR} \
- cmake_src_prepare
+ llvm.org_src_prepare
}
test_compiler() {
@@ -132,13 +125,11 @@ multilib_src_configure() {
if use test; then
local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
- local jobs=${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}
-
[[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="-vv;-j;${jobs};--param=cxx_under_test=${clang_path}"
+ -DLLVM_LIT_ARGS="$(get_lit_flags);--param=cxx_under_test=${clang_path}"
)
fi
cmake_src_configure
diff --git a/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild b/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
index bb151379aedf..01acafa1f815 100644
--- a/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
@@ -5,8 +5,7 @@ EAPI=7
CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{6..9} )
-inherit cmake-multilib llvm llvm.org multiprocessing python-any-r1 \
- toolchain-funcs
+inherit cmake-multilib llvm llvm.org python-any-r1 toolchain-funcs
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
HOMEPAGE="https://libcxx.llvm.org/"
@@ -35,9 +34,6 @@ BDEPEND="
DOCS=( CREDITS.TXT )
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
python_check_deps() {
has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
@@ -59,10 +55,7 @@ src_prepare() {
# out-of-tree build.
eapply "${FILESDIR}/${PN}-3.9-cmake-link-flags.patch"
- # cmake eclasses suck by forcing ${S} here
- CMAKE_USE_DIR=${S} \
- S=${WORKDIR} \
- cmake_src_prepare
+ llvm.org_src_prepare
}
test_compiler() {
@@ -133,13 +126,11 @@ multilib_src_configure() {
if use test; then
local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
- local jobs=${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}
-
[[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="-vv;-j;${jobs};--param=cxx_under_test=${clang_path}"
+ -DLLVM_LIT_ARGS="$(get_lit_flags);--param=cxx_under_test=${clang_path}"
)
fi
cmake_src_configure