summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-08-13 22:10:32 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-08-13 22:10:32 +0200
commit47097344d65802b639cd858f580a25687a438116 (patch)
tree6450d870fd88712951716c343509fffead81506b /sys-libs
parentwww-apps/karma-bin: 0.43 bump (diff)
downloadgentoo-47097344d65802b639cd858f580a25687a438116.tar.gz
gentoo-47097344d65802b639cd858f580a25687a438116.tar.bz2
gentoo-47097344d65802b639cd858f580a25687a438116.zip
sys-libs/glibc: Additional EAPI=7 fixes found by Arfrever
Package-Manager: Portage-2.3.70, Repoman-2.3.16 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 6e19a44aaa10..09bf788700f0 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -521,7 +521,7 @@ check_devpts() {
[[ ${MERGE_TYPE} == "buildonly" ]] && return
# Only sanity check when installing the native glibc.
- [[ ${ROOT} != "/" ]] && return
+ [[ -n ${ROOT} ]] && return
# If they're opting in to the old suid code, then no need to check.
use suid && return
@@ -609,7 +609,7 @@ sanity_prechecks() {
# Prevent native builds from downgrading
if [[ ${MERGE_TYPE} != "buildonly" ]] && \
- [[ ${ROOT} == "/" ]] && \
+ [[ -z ${ROOT} ]] && \
[[ ${CBUILD} == ${CHOST} ]] && \
[[ ${CHOST} == ${CTARGET} ]] ; then
@@ -1101,7 +1101,7 @@ src_configure() {
}
do_src_compile() {
- emake -C "$(builddir nptl)" || die "make nptl for ${ABI} failed"
+ emake -C "$(builddir nptl)"
}
src_compile() {
@@ -1166,7 +1166,7 @@ glibc_do_src_install() {
local builddir=$(builddir nptl)
cd "${builddir}"
- emake install_root="${D}/$(build_eprefix)$(alt_prefix)" install || die
+ emake install_root="${D}/$(build_eprefix)$(alt_prefix)" install
# This version (2.26) provides some compatibility libraries for the NIS/NIS+ support
# which come without headers etc. Only needed for binary packages since the
@@ -1348,7 +1348,7 @@ glibc_do_src_install() {
# Generate all locales if this is a native build as locale generation
if use compile-locales && ! is_crosscompile ; then
- run_locale_gen --inplace-glibc "${ED%/}/"
+ run_locale_gen --inplace-glibc "${ED}/"
sed -e 's:COMPILED_LOCALES="":COMPILED_LOCALES="1":' -i "${ED}"/usr/sbin/locale-gen || die
fi
}
@@ -1443,7 +1443,7 @@ pkg_postinst() {
if ! tc-is-cross-compiler && [[ -x ${EROOT}/usr/sbin/iconvconfig ]] ; then
# Generate fastloading iconv module configuration file.
- "${EROOT}"/usr/sbin/iconvconfig --prefix="${ROOT%/}/"
+ "${EROOT}"/usr/sbin/iconvconfig --prefix="${ROOT}/"
fi
if ! is_crosscompile && [[ -z ${ROOT} ]] ; then
@@ -1451,7 +1451,7 @@ pkg_postinst() {
# errors from this step #253697
/sbin/telinit U 2>/dev/null
- use compile-locales || run_locale_gen "${EROOT}"
+ use compile-locales || run_locale_gen "${EROOT}/"
fi
# Check for sanity of /etc/nsswitch.conf, take 2