summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-30 16:57:05 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-30 17:44:14 +0100
commit4771086f038d122bf1ba8fb81ab74fcb0a2da762 (patch)
treeef80080990babaa806a55767bcf780a5479b068d /sys-libs
parentprofiles: mask net-vpn/badvpn for removal (diff)
downloadgentoo-4771086f038d122bf1ba8fb81ab74fcb0a2da762.tar.gz
gentoo-4771086f038d122bf1ba8fb81ab74fcb0a2da762.tar.bz2
gentoo-4771086f038d122bf1ba8fb81ab74fcb0a2da762.zip
sys-libs/llvm-libunwind: Fix testing on non-native ABI
Closes: https://bugs.gentoo.org/824238 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-13.0.0.ebuild1
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-13.0.1.9999.ebuild1
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-13.0.1_rc1.ebuild1
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild1
4 files changed, 4 insertions, 0 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-13.0.0.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-13.0.0.ebuild
index 5e5505362a33..7878ad2cc3f1 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-13.0.0.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-13.0.0.ebuild
@@ -72,6 +72,7 @@ multilib_src_configure() {
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="$(get_lit_flags);--param=cxx_under_test=${clang_path}"
-DLIBUNWIND_LIBCXX_PATH="${WORKDIR}/libcxx"
+ -DLIBUNWIND_TARGET_TRIPLE="${CHOST}"
)
fi
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1.9999.ebuild
index 5d782b4128b2..c16a58ffa99e 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1.9999.ebuild
@@ -72,6 +72,7 @@ multilib_src_configure() {
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="$(get_lit_flags);--param=cxx_under_test=${clang_path}"
-DLIBUNWIND_LIBCXX_PATH="${WORKDIR}/libcxx"
+ -DLIBUNWIND_TARGET_TRIPLE="${CHOST}"
)
fi
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1_rc1.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1_rc1.ebuild
index 5d782b4128b2..c16a58ffa99e 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1_rc1.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1_rc1.ebuild
@@ -72,6 +72,7 @@ multilib_src_configure() {
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="$(get_lit_flags);--param=cxx_under_test=${clang_path}"
-DLIBUNWIND_LIBCXX_PATH="${WORKDIR}/libcxx"
+ -DLIBUNWIND_TARGET_TRIPLE="${CHOST}"
)
fi
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild
index 5d782b4128b2..c16a58ffa99e 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild
@@ -72,6 +72,7 @@ multilib_src_configure() {
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="$(get_lit_flags);--param=cxx_under_test=${clang_path}"
-DLIBUNWIND_LIBCXX_PATH="${WORKDIR}/libcxx"
+ -DLIBUNWIND_TARGET_TRIPLE="${CHOST}"
)
fi