summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2017-01-02 01:12:36 -0500
committerMike Frysinger <vapier@gentoo.org>2017-01-02 15:10:17 -0500
commit4914b70e25fdfbfa295c213928efb689bc10014b (patch)
tree0cea0108f88fc08e39e81cc84907210f0b6cdacc /sys-libs
parentsci-libs/scotch: Add flex-2.6.3 compatibility patch (diff)
downloadgentoo-4914b70e25fdfbfa295c213928efb689bc10014b.tar.gz
gentoo-4914b70e25fdfbfa295c213928efb689bc10014b.tar.bz2
gentoo-4914b70e25fdfbfa295c213928efb689bc10014b.zip
sys-libs/newlib: version bump to 2.5.0
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/newlib/Manifest1
-rw-r--r--sys-libs/newlib/newlib-2.5.0.ebuild82
-rw-r--r--sys-libs/newlib/newlib-9999.ebuild11
3 files changed, 86 insertions, 8 deletions
diff --git a/sys-libs/newlib/Manifest b/sys-libs/newlib/Manifest
index 93ddac4bde06..74a429690a17 100644
--- a/sys-libs/newlib/Manifest
+++ b/sys-libs/newlib/Manifest
@@ -4,3 +4,4 @@ DIST newlib-2.2.0.20150423.tar.gz 17485660 SHA256 b1ff3642b246adc6ee546884cb9ea3
DIST newlib-2.2.0.tar.gz 16521910 SHA256 f8add263b0737591aff451b12a00c262c2efac4fa87d741fa1c318fc3bb335be SHA512 ab9161f16845367c823b6709e3c5708969f29f05c77edb1cf969ff4202f358648f1e55080974599dcefed2fbced4694dc73748596e76c1aa37c50cddff6e4be3 WHIRLPOOL 8dfc23f93d774c5092d64d1482c3ecc6e3ba35395822bb1d52f5e3b86f644ee803927bff133883926f3e019cfd5d9f04ffe0dcaac20bdf144c542ba1dc3edff9
DIST newlib-2.3.0.20160104.tar.gz 17674117 SHA256 c92a0e02904bd4fbe1dd416ed94e786c66afbaeae484e4c26be8bb7c7c1e4cd1 SHA512 d83ce298b1b72eabf92e4ec14af3afdf3122e34aff5e320295a398df077235a78aa87148895b441a4f7de3047815e7ce13ea06a06135dd86b69a200236514293 WHIRLPOOL 41ab57955b886dad8988bd06a18c1b5bbf21c7b554410711c17141bbc12d70af2f6ce6f9d3503c11180d46b42bcf305c6347ea58252d24459dc02c568aeb8497
DIST newlib-2.4.0.tar.gz 17574364 SHA256 545b3d235e350d2c61491df8b9f775b1b972f191380db8f52ec0b1c829c52706 SHA512 c60665e793dce2368a5baf23560beb50f641e1831854d702d1d7629fb6e9200cf814527f29796792a3d2dff81afee4255723df99ceb0732f99dd9580a17d2ac0 WHIRLPOOL 34648a203286c8adc18bd38ae43ef389d0eb46e4280501250ab05b413d82e028a68abb4e331744e078eacad1d40c67178a1d12c39767da7cf89d0a49a7d8762f
+DIST newlib-2.5.0.tar.gz 17912392 SHA256 5b76a9b97c9464209772ed25ce55181a7bb144a66e5669aaec945aa64da3189b SHA512 4c99e8dfcb4a7ad0769b9e173ff06628d82e4993ef87d3adf9d6b5578626b14de81b4b3c5f0673ddbb49dc9f3d3628f9f8d4432dcded91f5cd3d27b7d44343cd WHIRLPOOL 45fdce47ecde0bb61367465ce2174cd3d00b5a034c0c204d19aba7850fd7d9151e89ad55c716ac0a7eba648f5e15d4ae0ca44f25cd7b27ed00f8968a53113f8a
diff --git a/sys-libs/newlib/newlib-2.5.0.ebuild b/sys-libs/newlib/newlib-2.5.0.ebuild
new file mode 100644
index 000000000000..6a325c787586
--- /dev/null
+++ b/sys-libs/newlib/newlib-2.5.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://sourceware.org/git/newlib-cygwin.git"
+ inherit git-r3
+else
+ SRC_URI="ftp://sourceware.org/pub/newlib/${P}.tar.gz"
+ if [[ ${PV} != *.201[5-9]???? ]] ; then
+ KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+ fi
+fi
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+fi
+
+DESCRIPTION="Newlib is a C library intended for use on embedded systems"
+HOMEPAGE="https://sourceware.org/newlib/"
+
+LICENSE="NEWLIB LIBGLOSS GPL-2"
+SLOT="0"
+IUSE="nls threads unicode crosscompile_opts_headers-only"
+RESTRICT="strip"
+
+NEWLIBBUILD="${WORKDIR}/build"
+
+pkg_setup() {
+ # Reject newlib-on-glibc type installs
+ if [[ ${CTARGET} == ${CHOST} ]] ; then
+ case ${CHOST} in
+ *-newlib|*-elf) ;;
+ *) die "Use sys-devel/crossdev to build a newlib toolchain" ;;
+ esac
+ fi
+}
+
+src_configure() {
+ # we should fix this ...
+ unset LDFLAGS
+ CHOST=${CTARGET} strip-unsupported-flags
+
+ local myconf=(
+ # Disable legacy syscall stub code in newlib. These have been
+ # moved to libgloss for a long time now, so the code in newlib
+ # itself just gets in the way.
+ --disable-newlib-supplied-syscalls
+ )
+ [[ ${CTARGET} == "spu" ]] \
+ && myconf+=( --disable-newlib-multithread ) \
+ || myconf+=( $(use_enable threads newlib-multithread) )
+
+ mkdir -p "${NEWLIBBUILD}"
+ cd "${NEWLIBBUILD}"
+
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable unicode newlib-mb) \
+ $(use_enable nls) \
+ "${myconf[@]}"
+}
+
+src_compile() {
+ emake -C "${NEWLIBBUILD}"
+}
+
+src_install() {
+ cd "${NEWLIBBUILD}"
+ emake -j1 DESTDIR="${D}" install
+# env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ # minor hack to keep things clean
+ rm -fR "${D}"/usr/share/info
+ rm -fR "${D}"/usr/info
+}
diff --git a/sys-libs/newlib/newlib-9999.ebuild b/sys-libs/newlib/newlib-9999.ebuild
index 9ef5293db416..6a325c787586 100644
--- a/sys-libs/newlib/newlib-9999.ebuild
+++ b/sys-libs/newlib/newlib-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI="4"
+EAPI="6"
-inherit flag-o-matic toolchain-funcs eutils
+inherit flag-o-matic toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://sourceware.org/git/newlib-cygwin.git"
@@ -44,10 +43,6 @@ pkg_setup() {
fi
}
-src_prepare() {
- epatch_user
-}
-
src_configure() {
# we should fix this ...
unset LDFLAGS