summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-10-14 00:00:00 +0000
committerMichał Górny <mgorny@gentoo.org>2020-10-14 23:14:22 +0200
commit5013eb101712d2ed08791660811f7c160368c1d9 (patch)
tree1f8bfe5e899126c7462a67b34314d142025cbbf7 /sys-libs
parentdev-ml/llvm-ocaml: Set used Python interpreter. (diff)
downloadgentoo-5013eb101712d2ed08791660811f7c160368c1d9.tar.gz
gentoo-5013eb101712d2ed08791660811f7c160368c1d9.tar.bz2
gentoo-5013eb101712d2ed08791660811f7c160368c1d9.zip
sys-libs/compiler-rt: Set used Python interpreter.
Required since: https://github.com/llvm/llvm-project/commit/c4c3883b00d3a6aa657a5e3e515c90c9ea1f81c6 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-11.0.0.9999.ebuild3
-rw-r--r--sys-libs/compiler-rt/compiler-rt-11.0.0.ebuild3
-rw-r--r--sys-libs/compiler-rt/compiler-rt-12.0.0.9999.ebuild3
3 files changed, 9 insertions, 0 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-11.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-11.0.0.9999.ebuild
index c83c56ecf249..f913057ff615 100644
--- a/sys-libs/compiler-rt/compiler-rt-11.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-11.0.0.9999.ebuild
@@ -22,6 +22,7 @@ CLANG_SLOT=${SLOT%%.*}
DEPEND="
>=sys-devel/llvm-6"
BDEPEND="
+ >=dev-util/cmake-3.16
clang? ( sys-devel/clang )
test? (
$(python_gen_any_dep ">=dev-python/lit-9.0.1[\${PYTHON_USEDEP}]")
@@ -76,6 +77,8 @@ src_configure() {
-DCOMPILER_RT_BUILD_PROFILE=OFF
-DCOMPILER_RT_BUILD_SANITIZERS=OFF
-DCOMPILER_RT_BUILD_XRAY=OFF
+
+ -DPython3_EXECUTABLE="${PYTHON}"
)
if use prefix && [[ "${CHOST}" == *-darwin* ]] ; then
diff --git a/sys-libs/compiler-rt/compiler-rt-11.0.0.ebuild b/sys-libs/compiler-rt/compiler-rt-11.0.0.ebuild
index bd92186599db..014a1f5ed815 100644
--- a/sys-libs/compiler-rt/compiler-rt-11.0.0.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-11.0.0.ebuild
@@ -22,6 +22,7 @@ CLANG_SLOT=${SLOT%%.*}
DEPEND="
>=sys-devel/llvm-6"
BDEPEND="
+ >=dev-util/cmake-3.16
clang? ( sys-devel/clang )
test? (
$(python_gen_any_dep ">=dev-python/lit-9.0.1[\${PYTHON_USEDEP}]")
@@ -76,6 +77,8 @@ src_configure() {
-DCOMPILER_RT_BUILD_PROFILE=OFF
-DCOMPILER_RT_BUILD_SANITIZERS=OFF
-DCOMPILER_RT_BUILD_XRAY=OFF
+
+ -DPython3_EXECUTABLE="${PYTHON}"
)
if use prefix && [[ "${CHOST}" == *-darwin* ]] ; then
diff --git a/sys-libs/compiler-rt/compiler-rt-12.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-12.0.0.9999.ebuild
index c83c56ecf249..f913057ff615 100644
--- a/sys-libs/compiler-rt/compiler-rt-12.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-12.0.0.9999.ebuild
@@ -22,6 +22,7 @@ CLANG_SLOT=${SLOT%%.*}
DEPEND="
>=sys-devel/llvm-6"
BDEPEND="
+ >=dev-util/cmake-3.16
clang? ( sys-devel/clang )
test? (
$(python_gen_any_dep ">=dev-python/lit-9.0.1[\${PYTHON_USEDEP}]")
@@ -76,6 +77,8 @@ src_configure() {
-DCOMPILER_RT_BUILD_PROFILE=OFF
-DCOMPILER_RT_BUILD_SANITIZERS=OFF
-DCOMPILER_RT_BUILD_XRAY=OFF
+
+ -DPython3_EXECUTABLE="${PYTHON}"
)
if use prefix && [[ "${CHOST}" == *-darwin* ]] ; then