summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-05-12 11:59:56 +0200
committerJeroen Roovers <jer@gentoo.org>2020-05-12 12:01:27 +0200
commit5339f103bb8ca8ebd621b4d020b319c0ee91f18d (patch)
tree5b8e687ca425ebca550111c9c8fff702ddc697b8 /sys-libs
parentnet-im/zoom: Add README.gentoo about display compositing. (diff)
downloadgentoo-5339f103bb8ca8ebd621b4d020b319c0ee91f18d.tar.gz
gentoo-5339f103bb8ca8ebd621b4d020b319c0ee91f18d.tar.bz2
gentoo-5339f103bb8ca8ebd621b4d020b319c0ee91f18d.zip
sys-libs/librtas: EAPI=7 and other minor fixes
- EAPI=7 - Do not install static libraries by default - Fix docdir - Prune libtool files Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/librtas/librtas-2.0.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-libs/librtas/librtas-2.0.2-r1.ebuild b/sys-libs/librtas/librtas-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..d366c246764b
--- /dev/null
+++ b/sys-libs/librtas/librtas-2.0.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A set of libraries for userspace access to RTAS on the PowerPC platform(s)"
+HOMEPAGE="https://github.com/ibm-power-utilities/librtas"
+SRC_URI="https://github.com/ibm-power-utilities/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64"
+IUSE="static-libs"
+
+DOCS="README"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install docdir=/usr/share/doc/${PF}
+ find "${D}" -name '*.la' -delete || die
+}