summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-03 19:08:15 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-03 19:09:27 +0100
commit625c72824647153264673e16d56a4f1729417506 (patch)
treeaa9a129024e15548f59386007f24538bd796d79e /sys-libs
parentsys-libs/compiler-rt-sanitizers: Add ABI_X86 flags (diff)
downloadgentoo-625c72824647153264673e16d56a4f1729417506.tar.gz
gentoo-625c72824647153264673e16d56a4f1729417506.tar.bz2
gentoo-625c72824647153264673e16d56a4f1729417506.zip
sys-libs/compiler-rt: Add ABI_X86 flags
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild11
-rw-r--r--sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild11
-rw-r--r--sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild11
3 files changed, 30 insertions, 3 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild
index d6a1a16eb346..ef78484f7721 100644
--- a/sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild
@@ -3,8 +3,10 @@
EAPI=7
+MULTILIB_COMPAT=( abi_x86_{32,64} )
PYTHON_COMPAT=( python3_{8..10} )
-inherit cmake flag-o-matic llvm llvm.org python-any-r1 toolchain-funcs
+inherit cmake flag-o-matic llvm llvm.org multilib-build python-any-r1 \
+ toolchain-funcs
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="https://llvm.org/"
@@ -94,6 +96,13 @@ src_configure() {
-DPython3_EXECUTABLE="${PYTHON}"
)
+ if use amd64; then
+ mycmakeargs+=(
+ -DCAN_TARGET_i386=$(usex abi_x86_32)
+ -DCAN_TARGET_x86_64=$(usex abi_x86_64)
+ )
+ fi
+
if use prefix && [[ "${CHOST}" == *-darwin* ]] ; then
mycmakeargs+=(
# setting -isysroot is disabled with compiler-rt-prefix-paths.patch
diff --git a/sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild b/sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild
index 23214f0469bf..59324e768209 100644
--- a/sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild
@@ -3,8 +3,10 @@
EAPI=7
+MULTILIB_COMPAT=( abi_x86_{32,64} )
PYTHON_COMPAT=( python3_{8..10} )
-inherit cmake flag-o-matic llvm llvm.org python-any-r1 toolchain-funcs
+inherit cmake flag-o-matic llvm llvm.org multilib-build python-any-r1 \
+ toolchain-funcs
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="https://llvm.org/"
@@ -94,6 +96,13 @@ src_configure() {
-DPython3_EXECUTABLE="${PYTHON}"
)
+ if use amd64; then
+ mycmakeargs+=(
+ -DCAN_TARGET_i386=$(usex abi_x86_32)
+ -DCAN_TARGET_x86_64=$(usex abi_x86_64)
+ )
+ fi
+
if use prefix && [[ "${CHOST}" == *-darwin* ]] ; then
mycmakeargs+=(
# setting -isysroot is disabled with compiler-rt-prefix-paths.patch
diff --git a/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild
index 0928ea166320..f8402de337a2 100644
--- a/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild
@@ -3,8 +3,10 @@
EAPI=7
+MULTILIB_COMPAT=( abi_x86_{32,64} )
PYTHON_COMPAT=( python3_{8..10} )
-inherit cmake flag-o-matic llvm llvm.org python-any-r1 toolchain-funcs
+inherit cmake flag-o-matic llvm llvm.org multilib-build python-any-r1 \
+ toolchain-funcs
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="https://llvm.org/"
@@ -94,6 +96,13 @@ src_configure() {
-DPython3_EXECUTABLE="${PYTHON}"
)
+ if use amd64; then
+ mycmakeargs+=(
+ -DCAN_TARGET_i386=$(usex abi_x86_32)
+ -DCAN_TARGET_x86_64=$(usex abi_x86_64)
+ )
+ fi
+
if use prefix && [[ "${CHOST}" == *-darwin* ]] ; then
mycmakeargs+=(
# setting -isysroot is disabled with compiler-rt-prefix-paths.patch