summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-04 19:47:03 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-04 20:01:20 +0100
commit72d73763a50ce8e6fcc54f7ebd84feeb7d09fee5 (patch)
tree4b5dbdc85c599547223476e1245e4ff4ca25e408 /sys-libs
parentsys-libs/libucontext: update EAPI 7 -> 8 (diff)
downloadgentoo-72d73763a50ce8e6fcc54f7ebd84feeb7d09fee5.tar.gz
gentoo-72d73763a50ce8e6fcc54f7ebd84feeb7d09fee5.tar.bz2
gentoo-72d73763a50ce8e6fcc54f7ebd84feeb7d09fee5.zip
sys-libs/compiler-rt: Try to workaround Portage bug pulling py3.10
Portage has a bug where repeated Python any-of (||) dependencies cause it to wrongly pull Python 3.10 instead of being happy with the installed interpreter. Put the non-test? Python dependency into "!test?" block to work around that. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild4
-rw-r--r--sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild4
-rw-r--r--sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild4
-rw-r--r--sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild4
4 files changed, 12 insertions, 4 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild b/sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild
index 564c29b11eaa..a2d62590de11 100644
--- a/sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-13.0.0.ebuild
@@ -26,7 +26,9 @@ BDEPEND="
$(python_gen_any_dep ">=dev-python/lit-9.0.1[\${PYTHON_USEDEP}]")
=sys-devel/clang-${PV%_*}*:${CLANG_SLOT}
)
- ${PYTHON_DEPS}"
+ !test? (
+ ${PYTHON_DEPS}
+ )"
LLVM_COMPONENTS=( compiler-rt )
LLVM_PATCHSET=${PV/_/-}
diff --git a/sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild
index 0a82b041cbde..1f0bd3af8c06 100644
--- a/sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-13.0.1.9999.ebuild
@@ -26,7 +26,9 @@ BDEPEND="
$(python_gen_any_dep ">=dev-python/lit-9.0.1[\${PYTHON_USEDEP}]")
=sys-devel/clang-${PV%_*}*:${CLANG_SLOT}
)
- ${PYTHON_DEPS}"
+ !test? (
+ ${PYTHON_DEPS}
+ )"
LLVM_COMPONENTS=( compiler-rt )
LLVM_PATCHSET=9999-1
diff --git a/sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild b/sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild
index 3c0553bcebbd..b2851d32c00e 100644
--- a/sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-13.0.1_rc1.ebuild
@@ -26,7 +26,9 @@ BDEPEND="
$(python_gen_any_dep ">=dev-python/lit-9.0.1[\${PYTHON_USEDEP}]")
=sys-devel/clang-${PV%_*}*:${CLANG_SLOT}
)
- ${PYTHON_DEPS}"
+ !test? (
+ ${PYTHON_DEPS}
+ )"
LLVM_COMPONENTS=( compiler-rt )
LLVM_PATCHSET=${PV/_/-}
diff --git a/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild
index 3d2048549e73..98c8fe855cfe 100644
--- a/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-14.0.0.9999.ebuild
@@ -26,7 +26,9 @@ BDEPEND="
$(python_gen_any_dep ">=dev-python/lit-9.0.1[\${PYTHON_USEDEP}]")
=sys-devel/clang-${PV%_*}*:${CLANG_SLOT}
)
- ${PYTHON_DEPS}"
+ !test? (
+ ${PYTHON_DEPS}
+ )"
LLVM_COMPONENTS=( compiler-rt cmake )
LLVM_PATCHSET=9999-1