summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-02-06 21:37:22 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-02-06 21:37:36 +0000
commit735a56979b7cd06cc57f236ab40fa0c04407cfff (patch)
treea56c455066eac6314b5679b10fb59caf042a09a4 /sys-libs
parentx11-terms/kitty: update DESCRIPTION (diff)
downloadgentoo-735a56979b7cd06cc57f236ab40fa0c04407cfff.tar.gz
gentoo-735a56979b7cd06cc57f236ab40fa0c04407cfff.tar.bz2
gentoo-735a56979b7cd06cc57f236ab40fa0c04407cfff.zip
sys-libs/glibc: unbreak cross-compilation
do_run_test() was called unconditionally for all CBUILD/CHOST/CTARGET combinations. This broke pkg_setup() for cross-*/glibc ebuild. Change moves do_run_test() back under native guard. Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.27-r1.ebuild12
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild12
2 files changed, 12 insertions, 12 deletions
diff --git a/sys-libs/glibc/glibc-2.27-r1.ebuild b/sys-libs/glibc/glibc-2.27-r1.ebuild
index c22600909bf0..2d395119b4bc 100644
--- a/sys-libs/glibc/glibc-2.27-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.27-r1.ebuild
@@ -599,6 +599,12 @@ sanity_prechecks() {
eerror " Downgrading glibc is not supported and a sure way to destruction."
die "Aborting to save your system."
fi
+
+ if ! do_run_test '#include <unistd.h>\n#include <sys/syscall.h>\nint main(){return syscall(1000)!=-1;}\n' ; then
+ eerror "Your old kernel is broken. You need to update it to a newer"
+ eerror "version as syscall(<bignum>) will break. See bug 279260."
+ die "Old and broken kernel."
+ fi
fi
# Users have had a chance to phase themselves, time to give em the boot
@@ -615,12 +621,6 @@ sanity_prechecks() {
die "Please fix your CHOST"
fi
- if ! do_run_test '#include <unistd.h>\n#include <sys/syscall.h>\nint main(){return syscall(1000)!=-1;}\n' ; then
- eerror "Your old kernel is broken. You need to update it to a newer"
- eerror "version as syscall(<bignum>) will break. See bug 279260."
- die "Old and broken kernel."
- fi
-
if [[ -e /proc/xen ]] && [[ $(tc-arch) == "x86" ]] && ! is-flag -mno-tls-direct-seg-refs ; then
ewarn "You are using Xen but don't have -mno-tls-direct-seg-refs in your CFLAGS."
ewarn "This will result in a 50% performance penalty when running with a 32bit"
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index d70a1523ed91..a3f9c3f2edc0 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -599,6 +599,12 @@ sanity_prechecks() {
eerror " Downgrading glibc is not supported and a sure way to destruction."
die "Aborting to save your system."
fi
+
+ if ! do_run_test '#include <unistd.h>\n#include <sys/syscall.h>\nint main(){return syscall(1000)!=-1;}\n' ; then
+ eerror "Your old kernel is broken. You need to update it to a newer"
+ eerror "version as syscall(<bignum>) will break. See bug 279260."
+ die "Old and broken kernel."
+ fi
fi
# Users have had a chance to phase themselves, time to give em the boot
@@ -615,12 +621,6 @@ sanity_prechecks() {
die "Please fix your CHOST"
fi
- if ! do_run_test '#include <unistd.h>\n#include <sys/syscall.h>\nint main(){return syscall(1000)!=-1;}\n' ; then
- eerror "Your old kernel is broken. You need to update it to a newer"
- eerror "version as syscall(<bignum>) will break. See bug 279260."
- die "Old and broken kernel."
- fi
-
if [[ -e /proc/xen ]] && [[ $(tc-arch) == "x86" ]] && ! is-flag -mno-tls-direct-seg-refs ; then
ewarn "You are using Xen but don't have -mno-tls-direct-seg-refs in your CFLAGS."
ewarn "This will result in a 50% performance penalty when running with a 32bit"