summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-02 18:25:24 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-02 18:30:36 +0200
commit86bc29f29ab6be3fb1e72e25c6e475b73d075609 (patch)
tree010092862eedc1a583d5d0c6bb6c51fb9aa9af03 /sys-libs
parentsci-visualization/gfsview: Don't set LIBS in global scope (diff)
downloadgentoo-86bc29f29ab6be3fb1e72e25c6e475b73d075609.tar.gz
gentoo-86bc29f29ab6be3fb1e72e25c6e475b73d075609.tar.bz2
gentoo-86bc29f29ab6be3fb1e72e25c6e475b73d075609.zip
sys-libs/db: Move CXXFLAGS alteration to local scope
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/db-3.2.9_p2.ebuild8
-rw-r--r--sys-libs/db/metadata.xml13
2 files changed, 10 insertions, 11 deletions
diff --git a/sys-libs/db/db-3.2.9_p2.ebuild b/sys-libs/db/db-3.2.9_p2.ebuild
index 06df0546aa1d..65f1809ddf13 100644
--- a/sys-libs/db/db-3.2.9_p2.ebuild
+++ b/sys-libs/db/db-3.2.9_p2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -33,12 +33,12 @@ IUSE="doc"
DEPEND="${RDEPEND}
=sys-libs/db-1.85*"
-# This doesn't build without exceptions
-export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
-
S="${WORKDIR}/${MY_P}"
src_unpack() {
+ # This doesn't build without exceptions
+ export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
+
unpack "${MY_P}".tar.gz
chmod -R ug+w *
diff --git a/sys-libs/db/metadata.xml b/sys-libs/db/metadata.xml
index 74fb0c9417a7..0f33890bd253 100644
--- a/sys-libs/db/metadata.xml
+++ b/sys-libs/db/metadata.xml
@@ -1,23 +1,22 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>base-system</herd>
-<longdescription>The Berkeley Database (Berkeley DB) is a programmatic toolkit
+ <herd>base-system</herd>
+ <longdescription>The Berkeley Database (Berkeley DB) is a programmatic toolkit
that provides embedded database support for both traditional and client/server
applications. Berkeley DB includes b+tree, queue, extended linear hashing,
fixed, and variable-length record access methods, transactions, locking,
logging, shared memory caching and database recovery. DB supports C, C++, Java,
and Perl APIs. DB is available for a wide variety of UNIX platforms as well as
Windows NT and Windows '95 (MSVC 4, 5 and 6).</longdescription>
-<longdescription lang="nl">De Berkeley Database is een programmatische toolkit
+ <longdescription lang="nl">De Berkeley Database is een programmatische toolkit
die embedded database support verzorg voor en traditionele en client/server
applicaties. Berkeley DB bevat b+tree, rij, uitgebreide lineaire hashing, vaste
en variabele lengte record toegangsmethoden, transacties, locking, logging,
gedeeld geheugen caching en database herstel. DB ondersteund C, C++, Java en
Perl API's. DB is beschikbaar voor veel UNIX platformen en
Windows.</longdescription>
-<use>
- <flag name='rpc'>Enable rpc client/server</flag>
-</use>
+ <use>
+ <flag name="rpc">Enable rpc client/server</flag>
+ </use>
</pkgmetadata>
-