summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-06-09 10:49:07 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-06-09 10:54:32 +0200
commit899640223af26224b534ca41cf4fa7225f5163d8 (patch)
tree23c2762dc8c5c37240df3ee5047801e086a7f582 /sys-libs
parentdev-python/babelfish: support Python-3.5 (diff)
downloadgentoo-899640223af26224b534ca41cf4fa7225f5163d8.tar.gz
gentoo-899640223af26224b534ca41cf4fa7225f5163d8.tar.bz2
gentoo-899640223af26224b534ca41cf4fa7225f5163d8.zip
sys-libs/e2fsprogs-libs: Bump to version 1.43.1
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/e2fsprogs-libs/Manifest1
-rw-r--r--sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.43.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/sys-libs/e2fsprogs-libs/Manifest b/sys-libs/e2fsprogs-libs/Manifest
index 72835dc7caf2..c42cca1a32f0 100644
--- a/sys-libs/e2fsprogs-libs/Manifest
+++ b/sys-libs/e2fsprogs-libs/Manifest
@@ -1,2 +1,3 @@
DIST e2fsprogs-libs-1.42.13.tar.gz 605222 SHA256 79ad28c14ffd12083d8c4efea04cff7d175faf070de03d29bc580b5f1b669a14 SHA512 803ec87f9b3926c1f423cac424dc7fe2bfbaa3237a93023fe0213b88e35b933090299304be1c47d876d9d14487acadea3e8b9a926dab24733dbe6ee3f1d846e0 WHIRLPOOL 0adb43e1dd0ea476729dfd455430d1b803e96985c6a190ec518e57f628da6c9a85e2389f877026492f3b757db2d470a175e54db9d608ec586536854e21c7462f
+DIST e2fsprogs-libs-1.43.1.tar.xz 394600 SHA256 a9ee6778d6e63fc995960f166de52d4d978923504fc94f275317e8cd740ea0ed SHA512 d48686230d42525b8f1b0b252d931f878e426410d84bc8360ff68baeb526edf6cc4d059ed6c72a59d01bb263e082f8f59806b0b914eb2ae76054e8b1633749b8 WHIRLPOOL be148ed32691923871b5e4cd924a1837d4125026af68dea29b463f190be32f468bdbbacb2994fab1b0ec73ee5e2454b5226300f9d951675d809bb7746f7206c8
DIST e2fsprogs-libs-1.43.tar.xz 394012 SHA256 130f1b9f35138eb6ac1fe2cbe291345fa3c1f270c2dbb209dcd7cfcc7773797b SHA512 b3fcae815d144760b209a274262c70a22902ebf664642330af47f39cbec8ea98645ac91a58efeb075eb08cb831911948e5a67f26510a3c2375415058cc48d0ee WHIRLPOOL c39f95b51ce39824cecdd2fa12ca3548ebfb8542153b0fdfee5be5e9df2364adf899e47a32afb806fb3d164d700ba218e7f23f96322e800fc58d312c32b3b77a
diff --git a/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.43.1.ebuild b/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.43.1.ebuild
new file mode 100644
index 000000000000..14e646d00dd8
--- /dev/null
+++ b/sys-libs/e2fsprogs-libs/e2fsprogs-libs-1.43.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+case ${PV} in
+*_pre*) UP_PV="${PV%_pre*}-WIP-${PV#*_pre}" ;;
+*) UP_PV=${PV} ;;
+esac
+
+inherit toolchain-funcs eutils multilib-minimal
+
+DESCRIPTION="e2fsprogs libraries (common error and subsystem)"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/e2fsprogs/${PN}-${UP_PV}.tar.xz
+ mirror://kernel/linux/kernel/people/tytso/e2fsprogs/v${UP_PV}/${PN}-${UP_PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~m68k-mint ~x86-solaris"
+IUSE="nls static-libs"
+
+RDEPEND="!sys-libs/com_err
+ !sys-libs/ss
+ !<sys-fs/e2fsprogs-1.41.8"
+DEPEND="nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P%_pre*}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.42.13-fix-build-cflags.patch #516854
+)
+
+src_prepare() {
+ printf 'all:\n%%:;@:\n' > doc/Makefile.in # don't bother with docs #305613
+ epatch "${PATCHES[@]}"
+}
+
+multilib_src_configure() {
+ local myconf=()
+ # we use blkid/uuid from util-linux now
+ if use kernel_linux ; then
+ export ac_cv_lib_{uuid_uuid_generate,blkid_blkid_get_cache}=yes
+ myconf+=( --disable-lib{blkid,uuid} )
+ fi
+ ac_cv_path_LDCONFIG=: \
+ ECONF_SOURCE="${S}" \
+ CC="$(tc-getCC)" \
+ BUILD_CC="$(tc-getBUILD_CC)" \
+ BUILD_LD="$(tc-getBUILD_LD)" \
+ econf \
+ $(tc-is-static-only || echo --enable-elf-shlibs) \
+ $(tc-has-tls || echo --disable-tls) \
+ $(use_enable nls) \
+ "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ emake V=1
+}
+
+multilib_src_install() {
+ emake V=1 STRIP=: DESTDIR="${D}" install || die
+ gen_usr_ldscript -a com_err ss $(usex kernel_linux '' 'uuid blkid')
+ # configure doesn't have an option to disable static libs :/
+ use static-libs || find "${ED}" -name '*.a' -delete
+}