summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-01 17:39:32 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-01 17:47:24 +0100
commita2e2309a6851200acea35fe0bd9040dbde507fa9 (patch)
treede25e40e204c74ccc7e54cf19517528a2e77063a /sys-libs
parentdev-libs/libixion: fix build with Clang (diff)
downloadgentoo-a2e2309a6851200acea35fe0bd9040dbde507fa9.tar.gz
gentoo-a2e2309a6851200acea35fe0bd9040dbde507fa9.tar.bz2
gentoo-a2e2309a6851200acea35fe0bd9040dbde507fa9.zip
sys-libs/llvm-libunwind: Set target triple unconditionally
While this is not strictly required for this package, set LIBUNWIND_TARGET_TRIPLE unconditionally for consistency with libc++ and libc++abi. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-13.0.0.ebuild2
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-13.0.1.9999.ebuild2
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-13.0.1_rc1.ebuild2
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild2
4 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-13.0.0.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-13.0.0.ebuild
index 7878ad2cc3f1..607404341462 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-13.0.0.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-13.0.0.ebuild
@@ -55,6 +55,7 @@ multilib_src_configure() {
-DLLVM_LIBDIR_SUFFIX=${libdir#lib}
-DLIBUNWIND_ENABLE_ASSERTIONS=$(usex debug)
-DLIBUNWIND_ENABLE_STATIC=$(usex static-libs)
+ -DLIBUNWIND_TARGET_TRIPLE="${CHOST}"
-DLLVM_INCLUDE_TESTS=$(usex test)
# support non-native unwinding; given it's small enough,
@@ -72,7 +73,6 @@ multilib_src_configure() {
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="$(get_lit_flags);--param=cxx_under_test=${clang_path}"
-DLIBUNWIND_LIBCXX_PATH="${WORKDIR}/libcxx"
- -DLIBUNWIND_TARGET_TRIPLE="${CHOST}"
)
fi
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1.9999.ebuild
index c16a58ffa99e..b2e400ff295b 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1.9999.ebuild
@@ -55,6 +55,7 @@ multilib_src_configure() {
-DLLVM_LIBDIR_SUFFIX=${libdir#lib}
-DLIBUNWIND_ENABLE_ASSERTIONS=$(usex debug)
-DLIBUNWIND_ENABLE_STATIC=$(usex static-libs)
+ -DLIBUNWIND_TARGET_TRIPLE="${CHOST}"
-DLLVM_INCLUDE_TESTS=$(usex test)
# support non-native unwinding; given it's small enough,
@@ -72,7 +73,6 @@ multilib_src_configure() {
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="$(get_lit_flags);--param=cxx_under_test=${clang_path}"
-DLIBUNWIND_LIBCXX_PATH="${WORKDIR}/libcxx"
- -DLIBUNWIND_TARGET_TRIPLE="${CHOST}"
)
fi
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1_rc1.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1_rc1.ebuild
index c16a58ffa99e..b2e400ff295b 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1_rc1.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1_rc1.ebuild
@@ -55,6 +55,7 @@ multilib_src_configure() {
-DLLVM_LIBDIR_SUFFIX=${libdir#lib}
-DLIBUNWIND_ENABLE_ASSERTIONS=$(usex debug)
-DLIBUNWIND_ENABLE_STATIC=$(usex static-libs)
+ -DLIBUNWIND_TARGET_TRIPLE="${CHOST}"
-DLLVM_INCLUDE_TESTS=$(usex test)
# support non-native unwinding; given it's small enough,
@@ -72,7 +73,6 @@ multilib_src_configure() {
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="$(get_lit_flags);--param=cxx_under_test=${clang_path}"
-DLIBUNWIND_LIBCXX_PATH="${WORKDIR}/libcxx"
- -DLIBUNWIND_TARGET_TRIPLE="${CHOST}"
)
fi
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild
index c16a58ffa99e..b2e400ff295b 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-14.0.0.9999.ebuild
@@ -55,6 +55,7 @@ multilib_src_configure() {
-DLLVM_LIBDIR_SUFFIX=${libdir#lib}
-DLIBUNWIND_ENABLE_ASSERTIONS=$(usex debug)
-DLIBUNWIND_ENABLE_STATIC=$(usex static-libs)
+ -DLIBUNWIND_TARGET_TRIPLE="${CHOST}"
-DLLVM_INCLUDE_TESTS=$(usex test)
# support non-native unwinding; given it's small enough,
@@ -72,7 +73,6 @@ multilib_src_configure() {
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="$(get_lit_flags);--param=cxx_under_test=${clang_path}"
-DLIBUNWIND_LIBCXX_PATH="${WORKDIR}/libcxx"
- -DLIBUNWIND_TARGET_TRIPLE="${CHOST}"
)
fi