summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-27 10:35:15 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-27 14:27:02 +0200
commitb78451bfa3081d1cb129bd99668ff51c880d5895 (patch)
treedfbe83ce9d35f57383aa33b1bf39637638234189 /sys-libs
parentsys-libs/libcxxabi: Modernize (diff)
downloadgentoo-b78451bfa3081d1cb129bd99668ff51c880d5895.tar.gz
gentoo-b78451bfa3081d1cb129bd99668ff51c880d5895.tar.bz2
gentoo-b78451bfa3081d1cb129bd99668ff51c880d5895.zip
sys-libs/libcxx: Modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxx/libcxx-15.0.0.9999.ebuild24
1 files changed, 16 insertions, 8 deletions
diff --git a/sys-libs/libcxx/libcxx-15.0.0.9999.ebuild b/sys-libs/libcxx/libcxx-15.0.0.9999.ebuild
index 0562667b5a4b..dcdce79b90b2 100644
--- a/sys-libs/libcxx/libcxx-15.0.0.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-15.0.0.9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..10} )
@@ -14,25 +14,33 @@ LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
KEYWORDS=""
IUSE="+libcxxabi +libunwind static-libs test"
-REQUIRED_USE="libunwind? ( libcxxabi )"
RESTRICT="!test? ( test )"
+REQUIRED_USE="libunwind? ( libcxxabi )"
RDEPEND="
- libcxxabi? ( ~sys-libs/libcxxabi-${PV}[libunwind=,static-libs?,${MULTILIB_USEDEP}] )
- !libcxxabi? ( >=sys-devel/gcc-4.7:=[cxx] )"
+ libcxxabi? (
+ ~sys-libs/libcxxabi-${PV}[libunwind=,static-libs?,${MULTILIB_USEDEP}]
+ )
+ !libcxxabi? ( >=sys-devel/gcc-4.7:=[cxx] )
+"
# llvm-6 for new lit options
# clang-3.9.0 installs necessary target symlinks unconditionally
# which removes the need for MULTILIB_USEDEP
-DEPEND="${RDEPEND}
- >=sys-devel/llvm-6"
+DEPEND="
+ ${RDEPEND}
+ >=sys-devel/llvm-6
+"
BDEPEND="
- ${PYTHON_DEPS}
+ !test? (
+ ${PYTHON_DEPS}
+ )
test? (
>=dev-util/cmake-3.16
>=sys-devel/clang-3.9.0
sys-devel/gdb[python]
$(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]')
- )"
+ )
+"
LLVM_COMPONENTS=( runtimes libcxx{,abi} llvm/{cmake,utils/llvm-lit} cmake )
LLVM_PATCHSET=9999-1