summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-27 10:35:12 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-27 14:27:01 +0200
commite6d4eb055ab7b9935be388f9a1461f3af87d503c (patch)
tree451d709cbbf4a0f3796a3a2707e416924520df81 /sys-libs
parentsys-libs/compiler-rt-sanitizers: Modernize (diff)
downloadgentoo-e6d4eb055ab7b9935be388f9a1461f3af87d503c.tar.gz
gentoo-e6d4eb055ab7b9935be388f9a1461f3af87d503c.tar.bz2
gentoo-e6d4eb055ab7b9935be388f9a1461f3af87d503c.zip
sys-libs/llvm-libunwind: Modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild
index 377022eb4033..6d871c89b6b1 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{8..10} )
@@ -16,16 +16,22 @@ KEYWORDS=""
IUSE="debug static-libs test"
RESTRICT="!test? ( test )"
-RDEPEND="!sys-libs/libunwind"
+RDEPEND="
+ !sys-libs/libunwind
+"
# llvm-6 for new lit options
DEPEND="
- >=sys-devel/llvm-6"
+ >=sys-devel/llvm-6
+"
BDEPEND="
- ${PYTHON_DEPS}
+ !test? (
+ ${PYTHON_DEPS}
+ )
test? (
>=sys-devel/clang-3.9.0
$(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]')
- )"
+ )
+"
LLVM_COMPONENTS=( runtimes libunwind libcxx llvm/cmake cmake )
LLVM_TEST_COMPONENTS=( libcxxabi llvm/utils/llvm-lit )