summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-05-16 11:24:32 -0400
committerMike Gilbert <floppym@gentoo.org>2021-05-16 11:29:53 -0400
commitea22eac608d06063ae7c8f689c425979f4728665 (patch)
tree3f49cfac330e4ff9b2dba2693fa49ce18d09180c /sys-libs
parentdev-python/zstandard: Enable python3.10 (diff)
downloadgentoo-ea22eac608d06063ae7c8f689c425979f4728665.tar.gz
gentoo-ea22eac608d06063ae7c8f689c425979f4728665.tar.bz2
gentoo-ea22eac608d06063ae7c8f689c425979f4728665.zip
sys-libs/libseccomp: keep native tools only in BDEPEND, sync live
Closes: https://bugs.gentoo.org/790533 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libseccomp/libseccomp-2.5.1.ebuild12
-rw-r--r--sys-libs/libseccomp/libseccomp-9999.ebuild11
2 files changed, 9 insertions, 14 deletions
diff --git a/sys-libs/libseccomp/libseccomp-2.5.1.ebuild b/sys-libs/libseccomp/libseccomp-2.5.1.ebuild
index fdc5755fe50d..b68cd3835b8d 100644
--- a/sys-libs/libseccomp/libseccomp-2.5.1.ebuild
+++ b/sys-libs/libseccomp/libseccomp-2.5.1.ebuild
@@ -30,16 +30,12 @@ REQUIRED_USE="
${PYTHON_REQUIRED_USE}
)"
-BDEPEND="
+DEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}
dev-util/gperf
- python? (
- ${PYTHON_DEPS}
- dev-python/cython[${PYTHON_USEDEP}]
- )
+ python? ( dev-python/cython[${PYTHON_USEDEP}] )
"
-DEPEND="${BDEPEND}"
-RDEPEND="${DEPEND}"
-
# We need newer kernel headers; we don't keep strict control of the exact
# version here, just be safe and pull in the latest stable ones. #551248
DEPEND="${DEPEND} >=sys-kernel/linux-headers-4.3"
diff --git a/sys-libs/libseccomp/libseccomp-9999.ebuild b/sys-libs/libseccomp/libseccomp-9999.ebuild
index 1d93b9496521..9df6cc592e47 100644
--- a/sys-libs/libseccomp/libseccomp-9999.ebuild
+++ b/sys-libs/libseccomp/libseccomp-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -30,13 +30,12 @@ REQUIRED_USE="
${PYTHON_REQUIRED_USE}
)"
-BDEPEND="
+DEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}
dev-util/gperf
- python? ( ${PYTHON_DEPS} )
+ python? ( dev-python/cython[${PYTHON_USEDEP}] )
"
-DEPEND="${BDEPEND}"
-RDEPEND="${DEPEND}"
-
# We need newer kernel headers; we don't keep strict control of the exact
# version here, just be safe and pull in the latest stable ones. #551248
DEPEND="${DEPEND} >=sys-kernel/linux-headers-4.3"