summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-07-23 08:12:09 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-07-23 08:14:33 +0100
commitf0835514f598eb471edd0d92dc29536afbbcb039 (patch)
tree356e3965b2da1a2cd3e86892473ee643a620b968 /sys-libs
parentdev-ada/gps: Add REQUIRED_USE (diff)
downloadgentoo-f0835514f598eb471edd0d92dc29536afbbcb039.tar.gz
gentoo-f0835514f598eb471edd0d92dc29536afbbcb039.tar.bz2
gentoo-f0835514f598eb471edd0d92dc29536afbbcb039.zip
sys-libs/glibc: expose a knob to downgrade glibc
It's not something to be used lightly. Useful when the damage was not yet done to the rest of the system. Usage example: # I_ALLOW_TO_BREAK_MY_SYSTEM=yes emerge -v1 "=glibc-${old-version}" Be prepared to deal with downgrade consequences like disappeared symbols and versions of symbols Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.29-r2.ebuild2
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.29-r2.ebuild b/sys-libs/glibc/glibc-2.29-r2.ebuild
index da78a273d19f..313e5c6b4404 100644
--- a/sys-libs/glibc/glibc-2.29-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.29-r2.ebuild
@@ -614,7 +614,7 @@ sanity_prechecks() {
if has_version ">${CATEGORY}/${P}-r10000" ; then
eerror "Sanity check to keep you from breaking your system:"
eerror " Downgrading glibc is not supported and a sure way to destruction."
- die "Aborting to save your system."
+ [[ ${I_ALLOW_TO_BREAK_MY_SYSTEM} = yes ]] || die "Aborting to save your system."
fi
if ! do_run_test '#include <unistd.h>\n#include <sys/syscall.h>\nint main(){return syscall(1000)!=-1;}\n' ; then
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 2b0697465d55..0ba2efb974c9 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -621,7 +621,7 @@ sanity_prechecks() {
if has_version ">${CATEGORY}/${P}-r10000" ; then
eerror "Sanity check to keep you from breaking your system:"
eerror " Downgrading glibc is not supported and a sure way to destruction."
- die "Aborting to save your system."
+ [[ ${I_ALLOW_TO_BREAK_MY_SYSTEM} = yes ]] || die "Aborting to save your system."
fi
if ! do_run_test '#include <unistd.h>\n#include <sys/syscall.h>\nint main(){return syscall(1000)!=-1;}\n' ; then