summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-12 11:53:40 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-12 16:25:29 +0100
commitf119161cba79476efb6547a1955cf1dd0ea51aac (patch)
tree3d7906bbf11d7f9a3eeb332854a04a958ebfd7e7 /sys-libs
parentdev-util/lldb: Switch to CMAKE_BUILD_TYPE=RelWithDebInfo (diff)
downloadgentoo-f119161cba79476efb6547a1955cf1dd0ea51aac.tar.gz
gentoo-f119161cba79476efb6547a1955cf1dd0ea51aac.tar.bz2
gentoo-f119161cba79476efb6547a1955cf1dd0ea51aac.zip
sys-libs/compiler-rt: Switch to CMAKE_BUILD_TYPE=RelWithDebInfo
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-9999.ebuild b/sys-libs/compiler-rt/compiler-rt-9999.ebuild
index 356ff8eea0fb..8f44cb9eb1c5 100644
--- a/sys-libs/compiler-rt/compiler-rt-9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-9999.ebuild
@@ -5,6 +5,8 @@
EAPI=6
: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+# (needed due to CMAKE_BUILD_TYPE != Gentoo)
+CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
# TODO: fix unnecessary dep on Python upstream
@@ -28,6 +30,9 @@ DEPEND="${RDEPEND}
test? ( ~sys-devel/clang-${PV} )
${PYTHON_DEPS}"
+# least intrusive of all
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
test_compiler() {
$(tc-getCC) ${CFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c - \
<<<'int main() { return 0; }' &>/dev/null