summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2021-05-10 20:58:36 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2021-05-10 20:59:06 +0200
commite95f11c4e55a2ae54b4cc02f171cde851e2388ba (patch)
treeefc519cac37b7bac923a28e65c6e684c20b90049 /sys-power/RyzenAdj/RyzenAdj-0.8.1.ebuild
parentsys-process/systemd-cron: amd64 stable (diff)
downloadgentoo-e95f11c4e55a2ae54b4cc02f171cde851e2388ba.tar.gz
gentoo-e95f11c4e55a2ae54b4cc02f171cde851e2388ba.tar.bz2
gentoo-e95f11c4e55a2ae54b4cc02f171cde851e2388ba.zip
sys-power/RyzenAdj: New package
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'sys-power/RyzenAdj/RyzenAdj-0.8.1.ebuild')
-rw-r--r--sys-power/RyzenAdj/RyzenAdj-0.8.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-power/RyzenAdj/RyzenAdj-0.8.1.ebuild b/sys-power/RyzenAdj/RyzenAdj-0.8.1.ebuild
new file mode 100644
index 000000000000..9bdcb5989b9c
--- /dev/null
+++ b/sys-power/RyzenAdj/RyzenAdj-0.8.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="The power management tool for mobile and desktop Ryzen APUs"
+HOMEPAGE="https://github.com/FlyGoat/RyzenAdj"
+SRC_URI="https://github.com/FlyGoat/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-apps/pciutils"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ CMAKE_BUILD_TYPE="Release"
+ cmake_src_configure
+}
+
+src_install() {
+ dosbin "${BUILD_DIR}"/ryzenadj
+
+ dodir "/usr/$(get_libdir)"
+ insinto "/usr/$(get_libdir)"
+ doins "${BUILD_DIR}"/libryzenadj.so
+
+ dodoc "${S}"/README.md
+}