summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-09-10 23:08:29 -0400
committerMike Gilbert <floppym@gentoo.org>2017-09-10 23:08:29 -0400
commit76453498956bf1f200788e53b2cb4d0dd351ea9b (patch)
treed3f1771d12e91851b5e96cdfb6461c5ee2994d5f /sys-power/cpupower/cpupower-3.18.ebuild
parentsys-apps/dbus-broker: new package (diff)
downloadgentoo-76453498956bf1f200788e53b2cb4d0dd351ea9b.tar.gz
gentoo-76453498956bf1f200788e53b2cb4d0dd351ea9b.tar.bz2
gentoo-76453498956bf1f200788e53b2cb4d0dd351ea9b.zip
sys-power/cpupower: remove old
Package-Manager: Portage-2.3.6_p60, Repoman-2.3.3_p38
Diffstat (limited to 'sys-power/cpupower/cpupower-3.18.ebuild')
-rw-r--r--sys-power/cpupower/cpupower-3.18.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/sys-power/cpupower/cpupower-3.18.ebuild b/sys-power/cpupower/cpupower-3.18.ebuild
deleted file mode 100644
index f31459e93566..000000000000
--- a/sys-power/cpupower/cpupower-3.18.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit multilib toolchain-funcs
-
-DESCRIPTION="Shows and sets processor power related values"
-HOMEPAGE="https://www.kernel.org/"
-SRC_URI="mirror://kernel/linux/kernel/v3.x/linux-${PV}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-IUSE="cpufreq_bench debug nls"
-
-# File collision w/ headers of the deprecated cpufrequtils
-RDEPEND="sys-apps/pciutils
- !<sys-apps/linux-misc-apps-3.6-r2
- !sys-power/cpufrequtils"
-DEPEND="${RDEPEND}
- virtual/os-headers
- virtual/pkgconfig
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/linux-${PV}/tools/power/${PN}
-
-pkg_setup() {
- myemakeargs=(
- DEBUG=$(usex debug true false)
- V=1
- CPUFREQ_BENCH=$(usex cpufreq_bench true false)
- NLS=$(usex nls true false)
- docdir=/usr/share/doc/${PF}/${PN}
- mandir=/usr/share/man
- libdir=/usr/$(get_libdir)
- AR="$(tc-getAR)"
- CC="$(tc-getCC)"
- LD="$(tc-getCC)"
- STRIP=true
- LDFLAGS="${LDFLAGS}"
- OPTIMIZATION="${CFLAGS}"
- )
-}
-
-src_unpack() {
- tar -xf "${DISTDIR}"/linux-${PV}.tar.xz \
- linux-${PV}/tools/power/${PN} \
- linux-${PV}/Makefile \
- || die
-}
-
-src_prepare() {
- # -Wl,--as-needed compat
- local libs="-lcpupower -lrt $($(tc-getPKG_CONFIG) --libs-only-l libpci)"
- sed -i \
- -e "/$libs/{ s,${libs},,g; s,\$, ${libs},g;}" \
- -e "s:-O1 -g::" \
- Makefile || die
-}
-
-src_compile() {
- emake "${myemakeargs[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" "${myemakeargs[@]}" install
- dodoc README ToDo
-
- newconfd "${FILESDIR}"/conf.d-r2 ${PN}
- newinitd "${FILESDIR}"/init.d-r4 ${PN}
-}