summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-09-12 15:12:20 -0400
committerMike Gilbert <floppym@gentoo.org>2017-09-12 15:13:29 -0400
commit807be3e849bf1ec12d52cd65cf03c339c1a59e53 (patch)
treea9b557d474a8e8a8b7f91b2f8dfa4d10d31ebe95 /sys-power/cpupower/cpupower-4.9.0-r1.ebuild
parentsys-apps/ripgrep: version bump to 0.6.0 (diff)
downloadgentoo-807be3e849bf1ec12d52cd65cf03c339c1a59e53.tar.gz
gentoo-807be3e849bf1ec12d52cd65cf03c339c1a59e53.tar.bz2
gentoo-807be3e849bf1ec12d52cd65cf03c339c1a59e53.zip
sys-power/cpupower: install cpupower.h
Bug: https://bugs.gentoo.org/593470 Package-Manager: Portage-2.3.6_p60, Repoman-2.3.3_p38
Diffstat (limited to 'sys-power/cpupower/cpupower-4.9.0-r1.ebuild')
-rw-r--r--sys-power/cpupower/cpupower-4.9.0-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-power/cpupower/cpupower-4.9.0-r1.ebuild b/sys-power/cpupower/cpupower-4.9.0-r1.ebuild
new file mode 100644
index 000000000000..87df9b4e8b03
--- /dev/null
+++ b/sys-power/cpupower/cpupower-4.9.0-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# eutils: strip-linguas
+inherit eutils systemd toolchain-funcs
+
+DESCRIPTION="Shows and sets processor power related values"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="cpufreq_bench debug nls"
+
+# File collision w/ headers of the deprecated cpufrequtils
+RDEPEND="sys-apps/pciutils
+ !<sys-apps/linux-misc-apps-3.6-r2
+ !sys-power/cpufrequtils"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ myemakeargs=(
+ DEBUG=$(usex debug true false)
+ V=1
+ CPUFREQ_BENCH=$(usex cpufreq_bench true false)
+ NLS=$(usex nls true false)
+ docdir=/usr/share/doc/${PF}/${PN}
+ mandir=/usr/share/man
+ libdir=/usr/$(get_libdir)
+ AR="$(tc-getAR)"
+ CC="$(tc-getCC)"
+ LD="$(tc-getCC)"
+ STRIP=true
+ OPTIMIZATION=
+ VERSION=${PV}
+ )
+
+ if [[ -n ${LINGUAS+set} ]]; then
+ strip-linguas -i po
+ myemakeargs+=( LANGUAGES="${LINGUAS}" )
+ fi
+
+ emake "${myemakeargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" "${myemakeargs[@]}" install
+ doheader lib/cpupower.h
+ dodoc README ToDo
+
+ newconfd "${FILESDIR}"/conf.d-r2 cpupower
+ newinitd "${FILESDIR}"/init.d-r4 cpupower
+
+ systemd_dounit "${FILESDIR}"/cpupower-frequency-set.service
+ systemd_install_serviced "${FILESDIR}"/cpupower-frequency-set.service.conf
+}